GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Bug when entering values

MantoManto Posts: 793Member
I'm continually having problems with changing attributes and using the expression editor. Even though I enter a value or expression and save it, it is reverted to the last value.

Example:
I have an attribute called timeleft. The value of it is 60. I change the value to 120 and start the preview. Then I see that the game ended after 60 seconds. I go back to the game attributes and see that timeleft is still 60.

Here's a video that explains the problem:


Anyone else having the same problem?

Comments

  • SolarPepperStudiosSolarPepperStudios Posts: 754Member
    Are you pressing the "Enter" or "Return" key when you are done entering the value? Sometimes if I don't then it will do the same thing.
  • ChimoruChimoru Posts: 137Member, PRO
    edited May 2013
    I know exactly what you mean. The expression editor has been glitchy for me ever since 10.2. I have a video of what seems to break it for me...




  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,913Member
    Yes this has been reported by me to both support and @codewizard they are aware of the issue.
  • GameLabs222GameLabs222 Posts: 197Member
    I usually just save, close, and restart. Can be a hassle though.

    It would also be nice if when setting simple values for rules and behaviors in the expression editor that you could just click in the field and type instead of opening the expression editor window. I've noticed if I fill in something simple I have a habit of typing it in the blue highlighted box without actually opening the expression editor. It will display like I've put in a value but when I go into the expression editor it's actually blank.

    Either it needs to actually change the value or it needs to display correctly.
  • CobraBladeCobraBlade Posts: 97Member
    Yes! This is driving me nuts. I'm plagued by this issue. You can't just leave a field, and you definitely can't edit an existing field, you have to completely type over everything because if you leave any of the existing text your also guaranteed to get this. The only safe way to enter values is to replace anything that exists in the field and end it by pressing Return... but then when you press return you move onto the next field... so a very frustrating bug.
  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,913Member
    edited June 2013
    If you edit a field after the edit press return this works 90% of the time. The cursor moves forward a few spots but I find that doesn't matter just hit the check box and I use this method everyday and it works well for me.
  • SlowboySlowboy Posts: 329Member, PRO
    Ditto to the driving em nuts part! Can't wait for this bug to get fixed. Development is literally taking twice as long at the moment.
    1. Edit
    2. Play
    3. Bug!
    4. Bug? Me?
    5. Edit...
    6. ZERO!
    7. Fix
    8. Play
    9. Works!

    So, the above should read 1. 2. 3. but with the current bug I am frequently taking 9 steps instead of the ideal 3. Please fix soon!!
    Ta
    Wayne
  • PBEmpirePBEmpire Posts: 676Member
    When you encounter this bug, exit the actor and enter the actor again. It is annoying but it works. I noticed this happens when you are typing in a number and then click away instead of pressing enter. Hope to see this fixed soon.
  • SlowboySlowboy Posts: 329Member, PRO
    Thanks PB, I'll try that! I forgot to mention actually that I am quite obsessive about pressing enter rather than clicking away - ever since there was a bug in publishing aaaages ago where the version number of your game wouldn't change unless you pressed enter :D
This discussion has been closed.