GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

SPACE BAR WONT WORK

ok so i dont know if this has been asked before and i am really sorry if it has. But im not sure if this is a bug with GS or im just doing it wrong.
so i have a word game and i need to put a space. i tried putting an actor when touch is pressed change Game.Typing to Game.Typing+Self.WhatletterAmI (Which is just a space)
this works great it works fine UNTIL... i save my work and close it. then when i decide to re open my app it somehow changes Self.WhatletterAmI to NOTHING. no space at all.

i then tried an idea from tshirtBooth which is to make a text game attribute and give it a value of (space) then did when touch is pressed change Game.typing to Game.Typing+(Text Attribute)
exactly them same thing happened it worked great but when i save it and close it and re open it, it changes the text attribute to nothing.

may be a GS error and i think it is because it doesnt save the space but was wondering if there was another way which worked even when saved and closed.

As i said before i am sorry if this has been asked i am new to GS and the community.
thanks everyone who does help if anyone :P

Comments

  • BlackCloakGSBlackCloakGS Posts: 2,250Key Master, Head Chef, Member, PRO GameSalad Employee
    Try using .. Instead of +. Plus only work with numbers. The dot dot operator is for text.
This discussion has been closed.