GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

iOS In-App Purchase Failed Help

GuyNextDoorGuyNextDoor Posts: 8Member, PRO
I am in need of help.
I tested my in-app purchase on add-hoc with sandbox tester and it works. But when I uploaded my binary to Apple and they tested it they rejected, giving this msg:

We found that your app exhibited one or more bugs, when reviewed on iPhone 5s running iOS 7.0.3, on both Wi-Fi and cellular networks, which is not in compliance with the App Store Review Guidelines.


I believed I have done everything right, including typing in the productID manually same as one in iTunes and also enabled in-app purchase on iTunes before submitting. I also double check to make sure my binary is using a publishing profile.

So what else could have caused this problem? I have sent my problem in for customer support (Spinach is handling it...Thanks by the way) and I am still waiting for a response after 3 days. What is the usual wait time for pro users anyway? (Not complaining just trying to gauge the average wait time for issues to be solved)

So anyone else who has encountered similar problems with iOS in-app purchase and care to share?

Answers

  • GamepencilerGamepenciler Artist/Game Developer Posts: 326Member, PRO
    apple has become strict in approvals I notice..

    Artist/Game Developer / Animator at your service..

  • KillerPenguinStudiosKillerPenguinStudios Posts: 1,291Member
    Hey @[email protected].com, I just recently uploaded my app with iAP in it and it was fine. Since you say you have tested in a sandbox version and it worked fine, the first thing that comes to mind is, when setting up everything in iTunes Connect, before you fully submitted the app to Apple, did you attach the iAP's to it and submit it alongside your app???
  • GuyNextDoorGuyNextDoor Posts: 8Member, PRO
    @ KillerPenguin: Do you mean enabled the IAP under the application settings before submitting when you mean attaching the IAP? If so then yes, if that's not what you mean then I have no idea how to attach IAP. I thought once you create the IAP under the application in iTunes you can use it in gamesalad with the productID.
  • mounted88mounted88 Posts: 1,113Member
    When you set up your screenshot and metadata in iTunes connect if your scroll down to the bottom you will see where to attach the IAP and Game Center to the app. That is what @killerpeguinstudios is referring to.

    He who knows nothing is closer to the truth than he whose mind is filled with falsehoods and errors.

  • GuyNextDoorGuyNextDoor Posts: 8Member, PRO
    @ mounted88 : I only see Enabled Gamecenter and IAP...Not attachment. But yes I did enabled both Gamecenter and IAP before submitting.
  • mounted88mounted88 Posts: 1,113Member
    Not enable. If you have 1 IAP. It will say 0 of 1 selected to submit. You have to make sure to select the IAP for the game. Before you submit it. See the attached pic of game center. It will be the same for IAP, before you submit it. It's located in iTunes connect-select your app-view details-scroll down below metadata almost towards the bottom.

    He who knows nothing is closer to the truth than he whose mind is filled with falsehoods and errors.

  • GuyNextDoorGuyNextDoor Posts: 8Member, PRO
    @mounted88 : I believed I did that. Right now I don't see it because my IAPs in iTunes are in the status" "Developer Action Needed" meaning it was disabled because of errors.

    But previously before I uploaded my binary I did enabled the IAPs and attached them. I think I get what you mean by attachment is when you select enabled and you need to choose which IAP to attached to the app right? Pretty sure I did that since I need to attached everything before even testing on ad hoc.
  • mounted88mounted88 Posts: 1,113Member
    Yes that's what I'm taking about.

    He who knows nothing is closer to the truth than he whose mind is filled with falsehoods and errors.

  • GuyNextDoorGuyNextDoor Posts: 8Member, PRO
    Yup did that. Thanks anyway for offering your help. Hope tech support can come to my rescue soon as I really have no idea how to solve this since I believe I did everything "correctly"...
  • KillerPenguinStudiosKillerPenguinStudios Posts: 1,291Member
    edited November 2013
    @guyNextDoor, I would go back and fourth from iAP in iTunes Connect and your project making sure the ID is definitely correct wording and everything. (It's also case sensitive remember!) Also make sure that if it's a consumable or non-consumable, you have that selected and they match up on both your project and iAP in iTunes Connect.

    Also, maybe in your project, delete the iAP's you have and start off fresh putting them in again! Just an idea!
  • GuyNextDoorGuyNextDoor Posts: 8Member, PRO
    @KillerPenguin, I double checked and the productIDs are all correct. Can it be that the function/behavior was corrupted?

    I'll try to remake all IAPs and test it again. Is there a limit to resubmitting to Apple?
  • KillerPenguinStudiosKillerPenguinStudios Posts: 1,291Member
    @GuyNextDoor, just some advice. When tagging someones name in a comment, make sure to put the full name because if you don't they won't get the notification that you are acknowledging them.

    That is a possibility and no, there's no limit to resubmitting to Apple. Just try and make sure it works before hand as they don't want to keep rejecting it for the same things.
  • GuyNextDoorGuyNextDoor Posts: 8Member, PRO
    @KillerPenguinStudios : Didn't know that. Thanks.

    I'll remake the IAPs and post again if it works.
  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,913Member
    Hmmm is that the bugs they were talking about? You're post doesn't say apple said issues with IAP only that they found some bugs.
  • stueynetstueynet TorontoPosts: 166Member

    I found that I was originally inputting the Product ID directly in the in app purchase behaviour Product ID field. I was getting errors. What I realized was that this field must take an attribute. So create a table and store the Product ID in there or create a local attribute in the button for the price. So you CANNOT input the product ID manually.

    My Latest GS Game - Tiny Spirit
    My First GS Game - Dashing Ralph

  • JDuaneJJDuaneJ San Francisco Posts: 300Member

    I'm having this problem currently. Everything worked in adhoc, and all IAPs were approved, but now when I download from the Store, nothing works and I get a failure. @stueynet I'm using tables and everything, even followed @FryingBaconStudios vids. Can't nail this one...

  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,913Member

    @stueynet said:
    I found that I was originally inputting the Product ID directly in the in app purchase behaviour Product ID field. I was getting errors. What I realized was that this field must take an attribute. So create a table and store the Product ID in there or create a local attribute in the button for the price. So you CANNOT input the product ID manually.

    This must be something new as I've always just typed in my product IDs. Make sure you stay away from special character et. Keep your IDs simple and in lowercase as this stuff is case sensitive. If there is still an issue then submit a bug report.

  • HELPmePLEASEHELPmePLEASE Posts: 5Member, PRO

    Sorry for asking such a novice question. This is my first time testing my game. Can someone please tell me how to get my app for testing in the sandbox environment ? I have already setup an adhoc provisioning profile, and in app purchase setup on iTunes connect and have my game loaded onto my device, i have also double checked the product id. However when I press the in app purchase it would say "In app purchase failed cannot connect to iTunes Store". Am I missing some steps? I feel so close yet so far :\

    Help would be much appreciated. Cheers

  • benbernhardbenbernhard Posts: 1Member, PRO

    Did you ever find a solution to your problem? I have the same problem. @GuyNextDoor‌

  • mangaspraimangasprai Posts: 35Member, PRO

    "Hi,

    Thank you for resubmitting your app. We test apps on iPads to make sure the app is compliant with Guideline 2.10. Upon re-review we find your app not to be in compliant with Guideline 2.2.

    We found that your app exhibited one or more bugs, when reviewed on iPad running iOS 7.1.1, on both Wi-Fi and cellular networks, which is not in compliance with the App Store Review Guidelines.

    Specifically, when buying gems, the purchase does not go through, but displays an error message.

    See attached screenshot.

    For discrete code-level questions, you may wish to consult with Apple Developer Technical Support. When the DTS engineer follows up with you, please be ready to provide:

    • complete details of your rejection issue(s)
    • screenshots
    • steps to reproduce the issue(s)
    • symbolicated crash logs - if your issue results in a crash log

    If you have difficulty reproducing a reported issue, please try testing the workflow as described in https://developer.apple.com/library/ios/qa/qa1764/Technical Q&A QA1764: How to reproduce a crash or bug that only App Review or users are seeing.
    Screenshot_0.png"


    Second time it happens. What did i do wrong? :(
    ah, i noticed that iAP are "waiting for review"...
    is that the problem? plus, they had problems with my english iap. It was: "buy 150 gems".
    where is the problem? :(

  • YatelandYateland Posts: 81Member, PRO

    I'm having the same problem!

  • baronedevelopbaronedevelop Posts: 9Member, PRO
    edited May 2014

    It looks like GameSalad RC 0.11.1.2 fixes this problem based on the release notes. I have the same problem and I am going to resubmit my app using this version.

    http://gamesalad.com/download/releaseNotes/creator/rc

Sign In or Register to comment.