GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Animation Q: Changing selected touch to 0 Alpha keeps animation from working

I am mystified. I have a scene with animation and I do not want the animation to start until a certain spot is touched to activate it. I put a control actor over the spot to touch. I set the control actor color's alpha to 0 so it is invisible. It does not work at all but when I put the alpha back on 1, it works fine and the animation begins but there is a nasty white square on my scene. Anyone know what I am doing wrong? I am just in testing phase so there are no other actors or scenes yet. Thank you.

Comments

  • SocksSocks London, UK.Posts: 12,822Member
    edited November 2013
    Weird, that should work fine, the value of the opacity shouldn't effect whether the control actor can be recognised or not ?

    You could turn 'visibility' off instead of setting the alpha channel to 0 - but I suspect there's something else weird going on here ?
  • brettw777brettw777 Posts: 24Member
    I tried that just now and it did not work either. Thanks.
  • quantumsheepquantumsheep Posts: 8,188Member
    edited November 2013
    Make a 'blank' graphic in Pixelmator or photoshop, or whatever you use to make images.

    Size won't matter but I recommend 16x16.

    Put this image into your game!

    Use it for your nasty white square instead of setting the alpha to 0 - The actor's alpha will remain 1, but as it's just showing a blank graphic, it might work! :D

    It's a workaround (as @Socks says, it should just be working) but it may help you get on.

    If this works, I fully expect you to say 'Thanks for nothing' :D

    Cheers,

    QS =D

    Dr. Sam Beckett never returned home...
    Twitter: https://twitter.com/Quantum_Sheep
    Web: http://www.quantum-sheep.com

  • brettw777brettw777 Posts: 24Member
    Quantumsheep, I actually kept messing with it and it finally took. I think I closed the program and restarted or something but I have it working. Thanks for nothing anyway!
Sign In or Register to comment.