GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Build 0.10.4.1d is available!

BlackCloakGSBlackCloakGS Posts: 2,250Key Master, Head Chef, Member, PRO GameSalad Employee
edited February 2014 in GameSalad Kitchen
Fixes:
Fixed issue with Playhaven not showing up on iPad and Universal iOS apps

This is just a binary update. Please republish to take advantage of these new binaries.
You do not need to update creator.

Comments

  • guillefaceguilleface Posts: 997Member
    wait so i summited 3 games on monday with playhaven and i did noticed the ads were not showing on adhoc mode, so either i lost 4 days and reupload my binary to apple, or my ads wont work?
  • neomanneoman Posts: 813Member
    edited February 2014
    @BlackCloakGS I thought I was loosing my mind ... I kept packaging and repackaging my universal apps ... I thought I was nuts as I didn't get a clear answer on my thread

    http://forums.gamesalad.com/discussion/63824/anyone-else-having-problems-displaying-playhaven-ads#latest

    then suddenly all is working ... Thanks for the fix but if I had known there was an issue it would have saved me a lot of time. Cheers ;-)
  • WbokoWboko Tennessee, USAPosts: 621Member, PRO

    wait so i summited 3 games on monday with playhaven and i did noticed the ads were not showing on adhoc mode, so either i lost 4 days and reupload my binary to apple, or my ads wont work?

    WOW that really blows... Welcome to the life of a GS game developer!
  • neomanneoman Posts: 813Member
    FYI @BlackCloakGS I got some bad news. The PlayHaven ads are still not working on universal builds on iPad. I have not tested on a pure iPad build. All I get is a black screen between scenes. It works great on the iPhone though. Cheers ... ;-)
  • lev82lev82 Posts: 5Member, PRO
    I'm also having problems. I just get a black screen during scenes on both iphone and universal builds. I've checked everything I can find, any help is appreciated.
  • saif_shammarisaif_shammari Posts: 128Member
    @BlackCloakGS
    Any new about RevMob?
  • hybridhybrid Posts: 183Member
    edited February 2014
    Did was iAds also having problems with Build 0.10.4.1c ?
    i got 2 apps approved like 2 days ago and still dont see any ads.

    it was universal ios also
  • neomanneoman Posts: 813Member
    @hybrid I have had no problems with iAds ... Give it a bit of time. My first game with iAds took 5 days or something like that ... I remember it was a long time before iAds appeared. If iAds appeared in your Ad Hoc then you should be good ... ;-)
  • hybridhybrid Posts: 183Member
    yes the iAds appear on the Ad Hoc.
    Hope it dont take too long to shown, i will give it some time.

    thanks!
  • neomanneoman Posts: 813Member
    @hybrid There is an issue with iAds if you install the iPhone packaged app on an iPad PlayHaven interstitial ads and iAds don't display. You get a black screen when you flip between scenes instead of an interstitial ad and a red bar on the top in place of an iAd but if you run the same .app on an iPhone it works as expected ... @BlackCloakGS if you need me to submit a bug report I am happy to do so ... Cheers
  • imGuaimGua Posts: 1,089Member
  • hybridhybrid Posts: 183Member
    thanks @neoman , but i dont used playheaven in my app, in the Ad Hoc it shows the ad, but in the published app i dont see neither the red bar. i will update if my app start receiving iads, but still nothing.
  • neomanneoman Posts: 813Member
    imGua said:

    Server updates fixed critical android bug in my game ^_^

    Well that is a good thing. It is good to know that the update fixed something :-)
  • BlackCloakGSBlackCloakGS Posts: 2,250Key Master, Head Chef, Member, PRO GameSalad Employee
    @neoman yes please submit a bug report
  • hybridhybrid Posts: 183Member
    Hi @BlackCloakGS
    i submit my app with Build 0.10.4.1c , did you know if iAds was having issues with that build? my app has like 3 days and still not receiving iads, in my previous apps it dint take so long to appear. the ads works on the ad hoc, but not in the publised app.
  • FatFishFatFish South East, UKPosts: 120Member
    hybrid said:

    Hi @BlackCloakGS
    i submit my app with Build 0.10.4.1c , did you know if iAds was having issues with that build? my app has like 3 days and still not receiving iads, in my previous apps it dint take so long to appear. the ads works on the ad hoc, but not in the publised app.

    I am experiencing the same issue here. No iAds displaying at all after 3 days so far. Test iAds appear in the adhoc build but nothing has displayed in the store build.
  • HQoovaHQoova Posts: 29Member, PRO
    FatFish said:

    hybrid said:

    Hi @BlackCloakGS
    i submit my app with Build 0.10.4.1c , did you know if iAds was having issues with that build? my app has like 3 days and still not receiving iads, in my previous apps it dint take so long to appear. the ads works on the ad hoc, but not in the publised app.

    I am experiencing the same issue here. No iAds displaying at all after 3 days so far. Test iAds appear in the adhoc build but nothing has displayed in the store build.
    Exact same deal with me. :/
  • neomanneoman Posts: 813Member
    @BlackCloakGS bug report submitted. Ads seems to work fine on my iPhone4s. I don't have an iPhone5 to test on. The issue seems to be affecting iPads regardless of the app build ie if it is universal, iPhone or an iPad app. It seems that ads are not working on the iPads ... Hope this helps.
  • hybridhybrid Posts: 183Member
    edited February 2014
    whom publish the app with build 0.10.4.1c i receive a answer from a bug report from gamesalad, it said that 0.10.4.1c has problems displaying ads, that publish with 0.10.4.1d should fix the problem. so the solution its to submit a update with the current build.
  • neomanneoman Posts: 813Member
    @BlackCloakGS Ok something has changed. I did another test. I packaged an iPhone app and ran it on my iPad with IOS 7 with the latest update. PlayHaven interstitial ads are working as expected but iAds just shows up as a red banner. One problem has been sorted one more to go. Hope this helps. I notified Bob from GS support.
  • HQoovaHQoova Posts: 29Member, PRO
    Apparently my iAds are up and running now, with build 0.10.4.1c
  • hybridhybrid Posts: 183Member
    @HQoova Yes, in both of my app are running as well. so it was an apple thing after all
  • neomanneoman Posts: 813Member
    edited February 2014
    I did another test. I packaged a base iPhone project as a universal build. Ads are working now as expected on both iPhone 4S running IOS 6 and iPad running IOS 7 with the latest patch. I didn't change anything except update the iPad with the latest IOS 7 patch. I will test an iPad only build and report the results. @BlackCloakGS Did anything change on your end ?
  • neomanneoman Posts: 813Member
    Sorry to bombard this thread. I did a test with an iPad only app. PlayHaven and iAds work as expected.

    I tested an iPhone only app again just incase. Both PlayHaven and iAds work fine on an iPhone 4S but when installed on an iPad running IOS 7 PlayHaven is ok but iAds don't work as expected. The iAd banner appears as a red banner and when you click it you get a white window. It looks like the issue is happening with an iPhone build installed on an iPad. I am not sure if the issue will happen with an iPad running IOS 6. Hope this clarifies things. Cheers and thank you.
  • FatFishFatFish South East, UKPosts: 120Member
    After 3+ days, iAds working on iPhone and iPad here also. As hybrid said, must have been an Apple thing. :)
  • marplumarplu Posts: 412Member, PRO
    Apple really wants to screw me... just got rejected with the same ad explanation. Binary made with 0.10.4.1d. I guess I have to delete the app in iTC and redo the whole thing :(
  • jignatowskijignatowski Posts: 7Member, PRO
    How do you download the nightly updates?
  • wpatenwpaten Posts: 281Member, PRO

    How do you download the nightly updates?

    The nightlies are for PRO members only. Onc eyou are logged in as pro they have a special link from the downloads page.
Sign In or Register to comment.