GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Problem When Placing Images Into GameSalad

TwilightHunterTwilightHunter Posts: 146Member
Hey, I have an issue when I put the images I make in Photoshop into Gamesalad. So what I do is draw an image and color it in Photoshop at the size I want it to be in the game I'm making. The problem is, when I put it into the game and test it, the image is extremely blurry. I have to transfer my images from my PC to my Mac because Photoshop is on my PC. I don't know if this has anything to do with the mess up, because when I just test something out and take a random image from the internet, (Say like some Metroid sprite or something) It goes into the game fine, with no blur. I'm guessing this is because the sprites I get form online are "sprited" and are clean pixels, whereas my photoshop files have a little too much going on. Any help would be great, thanks!

Comments

  • firemaplegamesfiremaplegames Posts: 3,206Member
    Your images are blurry because they have an odd dimension.

    All of your images have to have even dimensions to avoid the blur.

    i.e 24x356 instead of 24x355

    GameSalad centers everything, and if there is an odd dimension, that pixel will get split, causing a blur.
  • design219design219 Posts: 2,273Member
    No, they don't have to have an even dimension, you just have to uncheck "horizontal wrap" and "vertical wrap" under the "graphics" part of the "attributes" of an actor.
  • TwilightHunterTwilightHunter Posts: 146Member
    Oooh ok, So like (I figured as much but) if I had an image that was 64x64 it wouldn't be blurry correct? Because I was looking at one of my older game file and saw I used the same drawing method yet nothing was blurry, ok. Thanks alot!
  • design219design219 Posts: 2,273Member
    Hey, before you re-work your graphics, did you read my post above yours? We posted at the same time.
  • DhondonDhondon Posts: 717Member
    Save the images at 72dpi:)
  • firemaplegamesfiremaplegames Posts: 3,206Member
    Yes, design219's suggestion will work as well. If you don't need to resize the Actor during the game, you can also change both "horizontal wrap" and "vertical wrap" from stretched to fixed in the graphics attributes of the actor.
  • TwilightHunterTwilightHunter Posts: 146Member
    Oh wow, ok. I'll try all those things xD Thanks guys!
  • TwilightHunterTwilightHunter Posts: 146Member
    Ok, when I change the vertical and horizontal wraps to "Fixed" and test the game, the character is.. miniature I guess you could say. So he's this little tiny guy instead of how big he usually is. Got any suggestions?
  • Rob2Rob2 Posts: 2,402Member
    make sure image file is set to 72dpi otherwise GS will resize!! (its a bug, or feature, depending on how you look at it(I see six legs)).
  • TwilightHunterTwilightHunter Posts: 146Member
    Haha, quite the interesting "feature". xD
    I'll check it out, thanks!
  • TwilightHunterTwilightHunter Posts: 146Member
    How exactly would I go about changing the DPI setting?
  • Rob2Rob2 Posts: 2,402Member
    easiest way on a mac is the great underused preview!! So open image in OSX Preview (ie double click file with finder). Then from the menu bar along the top select TOOLS and then ADJUST SIZE and then set resolution to 72 pixels/inch making sure scale and resample are NOT ticked and then OK followed by file save!!
  • TwilightHunterTwilightHunter Posts: 146Member
    Hehe, Thanks man! Worked like a charm. I love OSX Preview xD Woot!
This discussion has been closed.