GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

App rejection due to In-App Purchase error

Hi there I'm trying to submit my game to Apple however twice now they have rejected it on account of -

"Specifically, we could not successfully download the In App Purchase.".

The thing is it works perfectly for me using an Ad-Hoc build distributed by testflight. I simply tap buy and the app shows a successful message but it seems when the apple employee tries they get an error (see screenshot)

..... So I really have no idea what to do as I can't even recreate the error. Is this some known issue at present ?

Quality & Affordable iOS, Android & Mac Developers: www.roksalt.co.

Comments

  • MoikMoik Posts: 257Member, PRO
    edited May 2014

    @Roksalt I think that means the app asked for product_unlock but the App Store sandbox didn't have it. Have you set up your iTunes Connect info?

  • daaddddaaddd Posts: 116Member

    This image means that the id on the project does not match with the itunesconnect inapp id , OR you maybe set your app ready to upload before adding the inapp to the app, try to put the app in developer rejected and then do again the inapp process, goo luck man.

  • RoksaltRoksalt Posts: 87Member

    Hmm ok I will try that.. Even though my app got rejected the IAP seems to still be in Review so I can't actually change anything on Apple's side.. I guess I have to just wait till they reject it?

    Quality & Affordable iOS, Android & Mac Developers: www.roksalt.co.

  • RoksaltRoksalt Posts: 87Member

    Can I ask though why it would work perfectly using Ad-Hoc Test flight builds and a "test user " account but then still fail this part?

    Quality & Affordable iOS, Android & Mac Developers: www.roksalt.co.

  • MoikMoik Posts: 257Member, PRO

    @Roksalt‌
    I'm not sure why :/
    Which RC of Game Salad did you build with? A recent one had IAP issues during submission for everyone (maybe it was the latest stable release). The most recent (like, last two days) had a fix related to IAP which would help submission. The error people were getting was different from yours I think, though.

  • FINNBOGGFINNBOGG Posts: 1,809Member

    Im starting to think that the count down clock on a GS users yearly subscription should be clicked off, whenever the customers app is rejected due to this ongoing issue. Its a featured that you are paying for and its a feature that is currently broken within GS. Then once this feature is " actually " fixed. Then the timer can proceed to count down for renewal.

  • Krehol GamesKrehol Games Posts: 42Member

    FINNBOGG,

    I agree. I purchased pro any thought I would get my money's worth by pumping out apps just to get rejected for IAP failing. We're losing time. I'm going to check for the release Moik is talking about above.

  • RoksaltRoksalt Posts: 87Member
    edited June 2014

    Hi there,

    So it took along time but Apple once again rejected my app -

    "2.2: Apps that exhibit bugs will be rejected"

    Specifically, we cannot download the In-App Purchases.

    The steps to reproduce are:

    1) Launch app,
    2) Tap the hero icon on the bottom right,
    3) Tap Buy,
    4) Enter iTunes password,
    5) App crashed,
    6) Relaunch the app,
    7) User is prompted to enter the iTunes password again,
    8) App crashes."

    Now as I mentioned I took this very same build and ran it on TestFlight and it works fine. So I assumed it was something I was doing during the submission process.

    In this version I took the following steps

    1 Created a new IAP in the latest GS Daily Build 000.254 and in iTunes Connect

    2 Added the new IAP to my button

    tableCellValue( game.||IAP|| ,1,1) 
    game.hero-Mode-Unlocked
    

    3 Published the app and jumped through all the hoops, then downloaded it to my machine and signed it with Ad-Hoc and uploaded to TestFlight... tested on my device [iPhone 5s and iPad mini first gen] and it worked perfectly.

    4 Logged into iTunes Connect and then added the IAP to my app and clicked "Ready to upload Binary" [As a side note I had host Content with Apple turned off]

    5 Rebuild and Resigned app with Distribution certificate and uploaded the app via Application Loader... with no errors

    6 Waited a few weeks and got rejected....

    WHAT THE HECK AM I DOING WRONG???????????

    PS I agree with @Moik, @FINNBOGG‌, @Krehol Games‌ this is one of the only Pro features i'm actually using so the fact that it doesn't work means I might as well flush my money down the toilet ;-)

    Quality & Affordable iOS, Android & Mac Developers: www.roksalt.co.

Sign In or Register to comment.