GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

app store rejection because won't go past splash screen

EclipseGamersEclipseGamers Posts: 91Member, PRO

my app has been rejected because it wont go past the 'splash screen' ? has anyone else had this problem and how do i resolve this?
thanks

Comments

  • gingagaminggingagaming FREELANCE GS DEV Posts: 1,584Member

    Have you uploaded your own splash screen when compiling your app?

  • EclipseGamersEclipseGamers Posts: 91Member, PRO
    edited June 2014
  • EclipseGamersEclipseGamers Posts: 91Member, PRO

    please help, this is my first time submitting an app and i cant see what im doin wrong?

  • gyroscopegyroscope I am here.Posts: 6,577Member, Sous Chef, PRO
    edited June 2014

    Hi @McClean91 Is your splash a single image with just a timer which after so many seconds, goes to the Menu?; or does it involve any animation, Interpolate behaviours, loading of any attributes, etc?

    ""You are in a maze of twisty passages, all alike." - Zork        temp domain http://spidergriffin.wix.com/alphaghostapps

  • EclipseGamersEclipseGamers Posts: 91Member, PRO

    it is just a single image with a timer of 3 seconds

  • EclipseGamersEclipseGamers Posts: 91Member, PRO

    iv have also added a loading screen when i setup my app before signing it on gamesalad website

  • jonmulcahyjonmulcahy Posts: 10,383Member, Sous Chef

    Did it work in adhoc mode? I'm guessing there is a bad rule (missing attribute) somehwere in your main scene , what you describe is the typical behavior when one is present, and those bad rules only show up when tested on a device only experience.

  • EclipseGamersEclipseGamers Posts: 91Member, PRO

    yes ive ad hoc tested and it works great

  • gyroscopegyroscope I am here.Posts: 6,577Member, Sous Chef, PRO

    @McClean91 said:
    it is just a single image with a timer of 3 seconds

    Hi, try remaking the Timer behaviour; then - if this behaviour shows Run to Completion checked uncheck it..... or if it's unchecked, check it.

    (Basically, there was a problem on older devices (I'm thinking iPad1 here) where one of those two options -but I can't remember which way around :wink: - was causing problems.

    So to repeat: if your first Timer as checked, uncheck the replacement, and if it's unchecked, check it.

    A final thing: go to Scene > Layers, and double click the actor(s) there, each in turn, to see if there's any Rules "hiding" that you've forgotten about which might be causing a conflict.

    Hope one of those things sorts it for you.

    ""You are in a maze of twisty passages, all alike." - Zork        temp domain http://spidergriffin.wix.com/alphaghostapps

  • EclipseGamersEclipseGamers Posts: 91Member, PRO

    the custom load up screen I've uploaded on game salad before signing is the same as the splash screen in my game so could it be getting stuck on the load up screen/

Sign In or Register to comment.