GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

IAP problem - Amazon

jigglybeanjigglybean Posts: 1,584Member

Hi all
This is a strange one. I have 2 games, one using the old IAP rules and one using the new one. Game A was working fine until the changes, Game B is working fine on Google Play with IAPs.

However, on Amazon - both are getting the same message from their testing team and I am bang out of ideas. Game A is currently live and the IAP is now not working with the error message '5. An error message"An error occurred while processing your purchase" is displayed.

Game A passed the IAP testing before my update and is live with IAP but gets the same error message, as I tried it again yesterday.

The IAP process will actually take you all the way to the payment gate, and thats where it appears to fail. So I am thinking its more than just code here.

I decided to update this with the new IAP rules but every single day now, both games are being rejected for this very same reason. The rules are fine, everything worked/s in testing but the same error message appears for both games, according to Amazon dev team.

I've redone the IAPs, checked/double checked the tables/names etc and everything looks fine but yet the error still appears.

Does anyone else have any ideas, or is this a new issue with Gamesalad and IAPs on Amazon with the new IAP tables? Because it seems funny how one works on google play, but not on Amazon.

Like Balls? Then click here! We've 100 coming soon

Comments

  • jigglybeanjigglybean Posts: 1,584Member

    bump. because this is really annoying me.

    The purchase table, the call back/product ID all match and works on google play, but on Amazon, the actual purchase (when you press to confirm buy) fails after you press it to login etc.

    Like Balls? Then click here! We've 100 coming soon

Sign In or Register to comment.