GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Prepping Android SDK (Windows)

Meta_XMeta_X Posts: 7Member

For the past couple days I've been trying to download the Android SDK so I can do the testing stufs with it. I followed the directions on Cookbook tutorial 6.4 "Preparing your PC for Android development (Part I)" (help.gamesalad.com/hc/en-us/articles/203082467)

Every time, after I install it and open the SDK Manager, all I see are Android SDK Tools and Android SDK Platform-tools, while the tutorial also says to check "Latest Android API (Currently 4.0.3, API 15)" and "Google USB Driver".

Here's more specifically what my SDK Manager looks like...
Tools>Android SDK Tools; API: [blank]; Rev: 18; Status: Update available: rev. 22
Tools>Android SDK Platform-tools; API: [blank]; Rev: 19; Status: Not installed
Extras>Android SDK Platform-tools, revision 19 [*]; API: [blank]; Rev. 19; Status: Installed
(Sorry bout all this textiness, idk how to post a screenshot)

I've tried it with multiple versions of java, including 1.7.0_01(which i already had), 1.6u30 (which is the one used in the tutorial), and 1.6.0_43 (which the link in the tutorial seems to go to).

So if anybody has any idea what's up, your advice would be much appreciated. Thanks a lot!

Comments

  • stragstrag Posts: 556Member, PRO

    I've tried to find advice about exactly what elements to download and what difference it makes if you don't have all the legacy ones but to no avail. I am in the process of getting a bigger hard drive so I can just download the whole bloody lot and be done with it. Unless there is anyone out there with some good advice? This is what the top of my sdk manager looks like....may help. Make sure you check the boxes if you want to install

    sdk.JPG 172.4K
  • Meta_XMeta_X Posts: 7Member

    When installing on my Mac it took forever, because it was downloading every one of those older builds... Although I have no idea whether it's actually necessary or not.
    Although with the PC my problem was that when I got to that window, there were only like four elements on that checklist, so not all of the ones mentioned in the guide were even showing up...
    Are you using JDK 6 or 7?

  • Meta_XMeta_X Posts: 7Member

    So i think i figured it out... instead of clicking on the file for the Android SDK given on the tutorial page, I went to the actual website and downloaded the newest version. Everything went fine this time.

Sign In or Register to comment.