GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

iPhone viewer crashes on launch

doublecrossdoublecross Posts: 3Member
edited 4:21AM in Tech Support
Unlike some people the whole procedure of installing provisional licences and certificates worked without any problems until I tried to finally launch GSV on the iPhone.

I have tried all available versions of GSV and they all do the same which is display the GS splash screen, then crash/quit.

The only thing that I have noticed different to the tutorial is how some frameworks are red (missing). Although I think this is fixed when I change the base SDK... or maybe this my problem?

Please someone help me out. I'm using 3GS with 4.0, iTunes 9.2 and xCode 3.2.3. I'm dying for this to work and I'm sooo close. Thanks!

Comments

  • IllumiProjIllumiProj Posts: 4Member
    Did you ever find a solution to this? I'm having the exact same issue, with the exact same hardware and software versions.
  • IllumiProjIllumiProj Posts: 4Member
    Okay, I figured it out. I noticed that when I installed GS Viewer, it replaced the icon for my app (which I had been publishing in the Gamesalad Creator and copying to my device in iTunes). So I went into my iTunes app list and deleted the program altogether, then resynced to get rid of it off my phone.

    Then I built GS Viewer to my iPhone again, and sure enough it loaded fine. I was then able to restart GS Creator and successfully preview the app on my phone.

    I guess the iPhone and XCode got confused due to the provisioning profile or something, but either way, just delete your app off the device before building GS Viewer and you should be good.

    Hope this helps.
This discussion has been closed.