GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Can't upload app

ShpintShpint Posts: 404Member
When I tried to upload my app through iTunes Connect, it keeps giving me this error

"The binary you uploaded was invalid. The signature was invalid, or it was not signed with an Apple submission certificate."

How can I fix this?
Thanks

Comments

  • ChunkypixelsChunkypixels Posts: 1,113Member
    Sounds like your trying to upload it using a Development Certificate, when it needs to be an Appstore Distribution Certificate.

    You need to go back onto the DevCentre and generate a new Distribution Certificate for the app, and rebuild the app using the new certificate.

    I think if youve downloaded and use the iOS4 SDK though, it should streamline the whole certificate process, and work it out for you. Or thats what Ive read elsewhere.
  • Rob2Rob2 Posts: 2,402Member
    +1
  • ShpintShpint Posts: 404Member
    Problem solved after watching tshirtbooth video
    Thank everyone
This discussion has been closed.