GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

What SDK version is needed?

tdistdis Posts: 7Member
When I try to publish an app to Gamesalad a window appears with the message "Receiving app". Then another window appears with the following:
"Code Signing Error -
Iphone publishing requires the Iphone SDK. Ensure that you have the latest Iphone SDK installed."

I have xcode 3.1.4 and Iphone SDK's 3.0, 3.1, 3.1.2, and 3.1.3 installed. I created a project directly in Xcode and it ran and installed on the itouch.

Do I need a more recent SDK? Version 4?
Do I need to specify somewhere what SDK I want to use for the Gamesalad project?
Any suggestions would be greatly appreciated.

Comments

  • JamesZeppelinJamesZeppelin Posts: 1,927Member
    To take advantage of Game Salads coolest feature you need the latest SDK

    The feature is the iphone viewer. It allows you to test your games instantly on your device without even being connected to the computer.
  • jweaver911jweaver911 Posts: 439Member
    I haven't updated to SDK 4 yet and I just published my update last week. You apparently don't need the very "latest" SDK version to publish and use the viewer.
  • JamesZeppelinJamesZeppelin Posts: 1,927Member
    Yeppers

    You just need it for the GS viewer.
    But the viewer is too rad to pass over.
  • suntzumobilesuntzumobile Posts: 34Member
    When attempting to publish my game, I'm receiving a "CODE SIGNING ERROR" it reads iPhone publishing requires the iPhone SDK. ensure that you have the latest iPhone SDK installed. I installed the latest 3.2.3 last night and I'm still getting this error, can you help
    if you don't need the Latest SDK why am I getting this error?

    thank you Don Wilcox/CEO SunTzu Mobile
  • tdistdis Posts: 7Member
    Thanks for everyone's quick feedback. I didn't know what else to do so I installed the latest iphone SDK (Version 4) and the latest version of xcode and the code signing error went away and I can now publish. I haven't tried the viewer yet. I don't understand why this worked.
This discussion has been closed.