GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Snow Leopard required?

JessieTeaJessieTea Posts: 10Member
I have Leopard installed on my MacBook that I'm planning on using for making iphone apps. I was wondering if I need Snow Leopard in this process. I read somewhere that for the newest version of xcode I need snow leopard but I'm not sure if that is true. Would I even need the newest version if I'm not planning on making iPad games?

Basically, is Snow Leopard necessary to make iPhone games?

Comments

  • firemaplegamesfiremaplegames Posts: 3,206Member
    Snow Leopard is required to make the GS Viewer app through XCode.

    This tool is amazing. It allows you to instantly and wirelessly test your games on your device.

    That is cool in itself, but its real power comes from when you are playing your game, it gives you critical real time info, like FPS and RAM usage. This app also lets you test on many devices. And it works in tandem with GameSalad Creator.

    From my point of view, this is critical if you want to make professional iPhone games. The older models of iPhones and iPod Touches have varying amounts of RAM and processor power.

    Just hoping that your game will work on them is a little scary.

    Snow Leopard has been out for a few years now, and they are not going to ever go back to Leopard. I'm sure that a new version of OSX will be out soon too...

    It is worth the 29$ upgrade in my opinion.
  • ChaserChaser Posts: 1,453Member
    No you dont need snow leopard to use GS but yes for the viewer or if you plan on just coding your game without GS. I make a dev profile for testing my apps
  • JessieTeaJessieTea Posts: 10Member
    Oh, I had no idea it was so cheap now. I'll get it ASAP. It doesn't seem like Leopard is that old to me but looking back I guess it is.

    Thanks for the help!
  • JamJarRiotJamJarRiot Posts: 62Member
    Isn't Snow Leopard required to compile to iOS4/Xcode 3.2.3 though ? And won't this be a requirement ?
This discussion has been closed.