GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Icon specified in the Info.Plist CFbundleIconFile does not have an extension

GameDevGameDev Posts: 14Member
Hey everyone,

About to submit my app, but when it comes to uploading i always get this error:

"Icon specified in the Info.Plist CFbundleIconFile does not have an extension: icon:

I tried to fix it by manually going into the info plist via show package contents, and changed "Icon" to "Icon.png". When I did that, I tried re uploading that but it gave me a code signing error.

So if I don't have it as "Icon.png" it gives me the icon error. If i have it as "Icon.png", it gives me a code signing error.

Is there anyway to fix this without getting a code signing error?

Please help me guys, i'm tearing my hair out right now.

Comments

  • GameDevGameDev Posts: 14Member
    Anyone? Please?
  • GameDevGameDev Posts: 14Member
    Anyone?
  • Rob2Rob2 Posts: 2,402Member
    have you tried doing a new upload to the gamesalad servers with a new icon file
  • GameDevGameDev Posts: 14Member
    Its not when I upload to gamesalad, its when I upload it to the app store.
  • Rob2Rob2 Posts: 2,402Member
    I understood that, so was saying you should do a fresh upload to gamesalad with a new icon file and try again. The file you upload to gamesalad can be anything.png but it should come back packaged as icon.png within your .app file.
  • GameDevGameDev Posts: 14Member
    Sure, ill give that a try.
  • GameDevGameDev Posts: 14Member
    Nope, reuploaded the 57x57 and the 512x512 with the same name, didn't work.
  • GameDevGameDev Posts: 14Member
    Any other solutions?
  • hrsmediahrsmedia Posts: 522Member
    I got this error when trying to upload through the application loader. I just done it through itunes connect and it worked.
    Does anyone know what this error is? I won't be able to upload binary through itunes connect after tomorrow.
  • jonbeebejonbeebe Posts: 49Member
    This is yet another incomplete thread regarding uploading through Application loader...

    This looks like its going to be a serious issue that'll need an immediate fix. I guess as more and more people need to submit their app, the more people will realize how serious it is when they can't...

    Someone please help! And if it's a prob with how GS packages apps, hopefully there will be a fix out soon...
  • Rob2Rob2 Posts: 2,402Member
    a quick look at the info.plist file... the icon file is just called 'icon' so I guess that didn't matter in the past but the better checking that is done by the uploader is flagging it as a problem...quick fix no panic.
  • JamesZeppelinJamesZeppelin Posts: 1,927Member
    interesting...

    I just uploaded with the application loader

    It was a binary compiled with an older version of GS

    the 5th line of info.plist was "icon.png"
    the latest version is just called "icon" no

    ill post this in the other thread as well
  • GameDevGameDev Posts: 14Member
    Thats the problem, I changed it to Icon.png, but when I reuploaded it, that error went away but it gave me a code signing error.

    I should probably download the latest version, I haven't been in gamesalad lately.
  • osalzanoosalzano Posts: 136Member, PRO
    I tried to upload through application loader and got the same error.
    Has anyone got a solution?
    Am I doing something wrong?
  • beefy_clyrobeefy_clyro Posts: 5,390Member
    Gendai ... care to post on this? I've just tried to submit my new app and receive the same thing! Whats going on?
  • POLYGAMePOLYGAMe Posts: 3,470Member
    It's definitely not just you guys. Me too. Luckily I got my app uploaded through iTunes Connect itself yesterday and it worked. App Loader gave me the same errors though.
  • beefy_clyrobeefy_clyro Posts: 5,390Member
    i thought we could only upload via app loader now?
  • POLYGAMePOLYGAMe Posts: 3,470Member
    Yup. Last night was the cutoff, I believe.
  • hrsmediahrsmedia Posts: 522Member
    I just logged into itunes connect, looks like you can still upload from there at the moment. Not sure how long you have..
  • scorelessmusicscorelessmusic Posts: 565Member
    *phew* NeuMET1K just made it through... Hope there's a fix for this issue soon.
  • beefy_clyrobeefy_clyro Posts: 5,390Member
    Just went into manage my application on itunes and when i clicked on my app there was a button saying upload binary so just done it there and it went through fine. I hope Gendai fix this soon because if they cut that off like they're going to we're all be in the same boat.
  • POLYGAMePOLYGAMe Posts: 3,470Member
    Yeah, GameSalad won't be much use if we can't submit our apps!
This discussion has been closed.