Game not working properly in GSViewer

specialist_3specialist_3 Member Posts: 121
edited November -1 in Tech Support
Hi there,

I have been developing a game of bouncing creeps. I finally got to test it on my itouch 3g but it is not working properly. On GS desktop preview, the game works perfectly but on my itouch, the creeps don't move. The game logic does not seem to work either. Collision detection is completely erratic with creeps flying off screen upon bouncing off the boundary or fellow creep.The timer does not count down. Sometimes the game just stops functioning. If I exit and reload gsviewer, it goes back to the same scene point at which i exited. This happened when I was having 8.7. So I updated my GS to 8.8 and also my Xcode to the latest. I am still experiencing the same problem. I have tried deleting and reinstalling it a few times but the problem persists. Is anyone else experiencing this? I am just a couple of days away from publishing my first game and need to do a full test but unable to.

My game project size is around 2mb, file size about 7.5mb, frame rates when it was working earlier were above 35fps. Memory usage is below 20mb. So I dont think the problem is with memory usage or slow fps...

Comments

  • JamesZeppelinJamesZeppelin Member Posts: 1,927
    First are you using the viewer or are you actually installing an .ipa on your device?
    I noticed you said you ipdated to 8.8 but, If using the viewer did you update an build the 8.8 viewer onto your 3g?

    You have to update the viewer xcode project everytime GS updates
  • jonbeebejonbeebe Member Posts: 49
    I've never had that issue, but reading over other threads it seems like your problems SHOULD be fixed as long as you...

    Make sure you have the latest version of GS (0.8.8)

    Make sure you have the latest version of the GS Viewer Built on Your Device (0.8.8) -- Make sure to remove the old one first!

    Save the Game Before You Preview on Your iDevice

    ...

    Then everything should work fine for you... Let us know how it goes.
  • specialist_3specialist_3 Member Posts: 121
    @Zeppelin - using the viewer bro. i downloaded the GameSalad iPhone Viewer 0.8.8.
    I also installed the latest xcode 3.2.3 and built the 4.0 release. Is this what you are referring to or am I missing out something.
  • specialist_3specialist_3 Member Posts: 121
    @jonbeebe - thats what i have done. i am up to date on the software aspects now. The game work perfectly on GS Preview not on viewer. I just dont get it. Creeps arent moving, numbers on interface (such as timer, random images) wont change. when i touch the creeps, nothing is happening.
  • firemaplegamesfiremaplegames Member Posts: 3,206
    With iOS4, clicking the Home button simply 'pauses' your app.

    For testing, you'll need to force-quit the GS Viewer by double-clicking the Home button to open the recent apps, then holding down the icon until it shakes and pressing the delete icon.

    For you issues, sometimes corrupt images or sounds can cause problems with the Viewer.

    I would make a duplicate of your game and just start chopping things out, one at a time. Tesy after each deletion. Hopefully you can narrow down the culprit.

    Did it use to work on the viewer, and it just recently started having issues?

    Can you open a previous version and see if that works?
  • specialist_3specialist_3 Member Posts: 121
    Hi Joe,

    I will try out your method.

    Yes it used to work on the viewer. Until like 1 1/2 days ago. Between then and my first post here, I hadn't done any testing and I had done quite a bit of work on the game. But the logic is quite the same between the one that worked and the current one.

    Now, I tried the previous version to see if it worked...it doesn't. That's what really bugs me now. You remember I was working on a TD project?...that got a little out of control as it became more complex. I decided to shelf it for the time being but use what I learnt and the artwork to work on a new and simpler project. Even that TD is not working properly now.
  • specialist_3specialist_3 Member Posts: 121
    Joe, the double clicking part works.

    As for the narrowing down the culprit, its just not happening. Imagine, my boundaries start flying when the creeps hit them. They are unmovable. And on certain maps, out of 7-8 creeps, only one moves and when it hits other creeps, those creeps start flying off-screen.

    Just to check, I have an accelerate method and in the direction, i use game.time%360 to create the randomness in movement. Some threads have been reporting issues with timer...so i removed timer related movement and replaced with some hardcoded number but still they won't move.
  • firemaplegamesfiremaplegames Member Posts: 3,206
    Apparently v. 0.89 fixed the Timer issues?
    I didn't have any before, so I cannot verify.
  • specialist_3specialist_3 Member Posts: 121
    Yes downloaded it just now and testing it. Still won't work. Very worked up now. I may have to start again from scratch.

    I tried saving as another project file to work on it...still the same result. I tried opening a 2-day old version of this game. In that version, the creeps can move but the touch and certain actors and logic associated with those actors wont work consistently. And different maps seem to function differently.
  • specialist_3specialist_3 Member Posts: 121
    In fact, to see if size of project is being an issue, I deleted certain maps on a copied version, still wont budge.
  • firemaplegamesfiremaplegames Member Posts: 3,206
    hmmm. Just for the fun of it, you can try restarting your iPhone. Maybe that will clear out some cobwebs.

    I'm sorry you're having problems!
  • specialist_3specialist_3 Member Posts: 121
    Ok...just did that a couple of times..same problem. I hate the idea of redoing this game man.
Sign In or Register to comment.