Help : Impossible to publish my game : connection Failed, the request timed out

galbangalban Member Posts: 62
edited November -1 in Tech Support
When i try to publish my game, i obtains the message after the upload processus "connection Failed, the request timed out",
My project size : 50,7 Mo
If i try with an old version of my project (40 Mo), it's works

No it's impossible to pubish my game,50 Mo is a gamesalad limit ???

Comments

  • SingleSparqSingleSparq Member Posts: 1,339
    Same issue (posted to forum yesterday but no response from anyone). Although it's not nice to see others having problems, I'm glad I'm not alone. My file size is under 20mg. I have sent a bug report to Gendai about it.
  • SingleSparqSingleSparq Member Posts: 1,339
    Taking my router out of the set up had no effect
  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 1,864
    We're looking into it, but it might take a while. It looks have something to do with transfer time to the particular user, so it's not a fixed size that causes problems.

    @SingleSparq / @galban How long do files that work for you take to go through?
  • SingleSparqSingleSparq Member Posts: 1,339
    When you say "work for you" as this is my first one I have not had any work. Is it okay for me to try and upload something else (smaller) as a test perhaps?
  • SingleSparqSingleSparq Member Posts: 1,339
    Tried again (with same game) and watched the console log - only errors I noticed were a couple like this, nothing else:

    10-07-25 1:43:17 PM [0x0-0x3d03d].com.gendaigames.GameSalad[411] libpng warning: Warning: Input PNG does not have an 8 bit input depth. Please convert your PNG to 8-bit for optimal performance on iPhone OS.
  • galbangalban Member Posts: 62
    Time transfert to upload the project : 14 minutes
    Tonight, it works. But it is very random. I tested it in wireless and ethernet

    I really need a solution, I have invested much time and money on this project and I am very worried.

    Sorry for my english, i'm french
  • firemaplegamesfiremaplegames Member Posts: 3,206
    @SingleSparq: Do you make your graphics in Photoshop?

    If so, if you open one of your images and go under the Image Menu => Mode, does it say 8-bit?

    It seems like your images might be 16-bit...
  • SingleSparqSingleSparq Member Posts: 1,339
    16 bit bad? With so many images it would be Photoshop, pixelmator, and that online service to crunch png's down. I can check I suppose but don't think that's causing the upload issue.
  • firemaplegamesfiremaplegames Member Posts: 3,206
    Yes, images need to be in 8-bit, not 16-bit.
    That goes for the icon as well.

    That seems to be what your error message above is telling me.

    And when I say everything needs to be an 8-bit image, I don't mean that everything needs to be an indexed PNG-8 image, which is only 256 colors.

    8-bit means 8-bits per color channel, which is 16.7 million colors.

    16 bits per channel give 32,769 colours per channel, which is actually 281 trillion possible colors!

    16-bit is only used for photo editing, images still need to be saved back down to 8-bit for printing.

    Pretty much every single thing you have ever seen on a computer is in 8-bit.
    And the iOS only supports 8-bit images as well.
  • SingleSparqSingleSparq Member Posts: 1,339
    Well went through the images in the package used - all are 8bit so not sure why the error comes up.
  • SingleSparqSingleSparq Member Posts: 1,339
    Tried 2 more times to upload - time from uploading to error 4mins 25 secs. Interestingly enough the error I got on the 1st of the 2 was the "policy has changed please go to Gendai.com" message.
  • SingleSparqSingleSparq Member Posts: 1,339
    Well it seems I am getting closer, no longer get the timed out error so Gendai if this was your doing then THANK YOU! You tend to get the short side of our anger stick at times and it's nice to see something work.

    Now if I can just get my certificates in order it may actually publish! Grrr...
  • MightyBooshMightyBoosh Member Posts: 83
    For anyone wondering I just got a successful Distribution build for "Kamikaze Ninjas vs Pirate Pig" so the uploader seems to be doing fine. Took around 10 min to build and the file size is 28.8 MB.

    Hope that helps
Sign In or Register to comment.