Importing a table now takes 90 seconds, instead of 2 seconds.

2»

Comments

  • ArmellineArmelline Member, PRO Posts: 4,957

    @Hymloe I tried importing your table and it took beachball amounts of time. I made a randomly populated table slightly bigger, and it imported immediately. Weird :( Seems to maybe be something to do with the contents of your table?

  • HymloeHymloe Member Posts: 1,651

    I would definitely appreciate it if the GS Team could take a look at that table issue.

    And see if importing the table takes a long time for them. And if so, debug and fix any issues found.

  • HymloeHymloe Member Posts: 1,651

    Here's another table to try... does this one also take a long time to import into GS? I'd appreciate it if anyone could give it a go and let me know how you went...

    http://www.muzboz.com/Host/GameSalad/Map1_Revealed.csv

  • tmanntmann Member Posts: 278

    @Hymloe sorry I should have said, GS load times of your file was very long.. I ended up going to make a coffee.

  • HymloeHymloe Member Posts: 1,651
    edited August 2015

    Sometimes I think GS is just putting in strange things to bring my projects to their knees. But that's just crazy, isn't it? :)

    It's like in "The Twits" where they sneak in and fill up the old man's toothpaste with glue, and make his walking stick a tiny bit shorter each night, so he begins going insane.

    Seriously... why doesn't this stuff just work?

  • HymloeHymloe Member Posts: 1,651

    For me, importing the Map1_Revealed.csv take about 29 seconds.

    That was saved from Excel on Windows 7. So, a completely different versions of Excel, on a different OS that what I usually use.

    I tried importing it into GS 0.13.31 on my Macbook Air this time. (My Air is running OSX 10.9.4, while my Macbook Pro is running 10.8.5).

    So I'm getting the same results across all my machines, using a bunch of different software.

    My Map1.csv table has lots of text, including "-" and "_" characters.

    While the Map1_Revealed.csv table only has 0 and 1 characters.

    So, what's going on?

  • HymloeHymloe Member Posts: 1,651

    Just tried in GS 0.13.33, and it took 30 seconds to import the Map1_Revealed.csv.

    It's just a table of 0s and 1s! (Importing as integers without row and column titles).

    GS, please help. What's going on here? Please fix ASAP.

    Un-cripple your build please.

  • GeorgeGSGeorgeGS Key Master, Head Chef, Member, PRO Posts: 478

    I'm not saying that table importing is perfect. It may very well be slow and we can probably fix that.

    The issue I have is that there are at least 3 different issues mentioned in the bug. I asked for more information about the two that are not related to table importing because when we try to duplicate a bug and fix it we want to fix the whole thing. Without a way to duplicate the other two issues we can't be sure we fixed them all, that's why it's better to make a bug focused on one issue and if you have more issues make more bugs.

    In the interest of getting this looked at I'm going to edit the bug to only refer to the slow importing. When you're able to show us how to duplicate the other issues, please make a new bug for each one.

  • HymloeHymloe Member Posts: 1,651

    Sure, sounds good. Thanks for that.

    I'm hoping that the fix for the slow importing might point at the problem for the Copy Table slowdown. So let's see how you go fixing the slow import issue, and I can take another stab at the other issues once that's done, I guess.

    Maybe you should copy and paste the text from the original bug as a comment on the bug and say "FYI: this is some further information that might be related". So the info is not lost on the sands of time.

  • HymloeHymloe Member Posts: 1,651

    You're a hero @GeorgeGS ... you can do it! :)

  • GeorgeGSGeorgeGS Key Master, Head Chef, Member, PRO Posts: 478

    The rest of the info is still there, I just edited the title to be more specific about the import issue.

    I have an idea why it's slow but haven't really been able to take a good look at it. CSV parsing is generally very simple, except for those cases where it isn't, like quoted fields with embedded commas and carriage returns. There's a lot of work done to handle those complicated cases and we may be able to simplify that a bit for tables that don't need it.

    Everyone is a bit backed up right now, but we won't forget it when we can free up some time. :)

  • HymloeHymloe Member Posts: 1,651

    Great. Just so you know, this has crippled my latest game project. So I'm waiting on a fix.

    That's two projects that no longer work properly. Just saying.

  • HymloeHymloe Member Posts: 1,651

    Paying monthly seems a bit more painful, when you can count each month that a bug still exists which disallows development on your game.

  • GeorgeGSGeorgeGS Key Master, Head Chef, Member, PRO Posts: 478

    Well, to be fair, importing taking longer than it used to is annoying but in no way crippling which is why I was looking for information on the other issues that seem more severe. It sounds like even if table importing was instant that you have other issues and I'd love to be able to look at those if you can distill them into a relatively small focused example.

  • HymloeHymloe Member Posts: 1,651
    edited August 2015

    I totally appreciate that. :)

    Not sure how to help there, at present though.

    Currently the best I think I can hope for, is a quick fix to importing, that may prove itself to reveal / fix the issue with Copy Table... perhaps revealing itself to be some element of the data or CSV format that GS is not handling well/quickly in both cases.

    But yes, I'll try to find some time to try to create a simple project that reproduces the Copy Table slowdown. As yes, that would be great to have, to get to the run-time problem head on. :)

Sign In or Register to comment.