GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Background is white. HALP.

peachpellenpeachpellen Posts: 977Member
Help me!

I've finally got my devices to test on and my background is going white for a game, when I have a wall actor covering the whole of it.

Am I doing it wrong? /chinscratch

Any help is greatly appreciated, I want to get this working PERFECTLY ^-^;

Comments

  • BarkBarkCoBarkBarkCo Posts: 1,400Member
    Is the version of the viewer you are running different than the version of GS you are building the game with?
  • peachpellenpeachpellen Posts: 977Member
    Both are the absolute newest. Could this be just a viewer problem? If there is any chance of that I could try AdHoc?

    What do you think? (Ignore the stench of desperation, lol.)
  • BarkBarkCoBarkBarkCo Posts: 1,400Member
    Yeah, if ad hoc works, it could be a viewer w/iPhone 4 "issue".
  • peachpellenpeachpellen Posts: 977Member
    Alright, will go and attempt that - will then update the thread as I couldn't find any other questions about it.
  • expired_012expired_012 Posts: 1,802Member
    I had the same problem. Do you have an extra layer over your background covering the whole screen like a border around the screen or something? If so, delete the layer and you should be fine.

    Try and AdHoc and see what happens.
  • peachpellenpeachpellen Posts: 977Member
    AdHoc failed >.<;

    I have other layers in which I have various objects, including a border - but the border is 4 objects, not a whole square. (This was for a practical reason.)

    Could any of that be doing it?

    I will go and check once again that there is nothing covering the entire screen.
  • expired_012expired_012 Posts: 1,802Member
    As a test, just try putting your background over every other layer including your small objects and actors and see if it then shows in the viewer.
  • peachpellenpeachpellen Posts: 977Member
    Ooooh that is a good point. I was going to do that then got distracted. Off trying that and one other thing now, then will update here again. :)
  • peachpellenpeachpellen Posts: 977Member
    BAH.

    The image is showing up as white - it's just white.

    I'm going to go and save it in some other format.
  • design219design219 Posts: 2,273Member
    When you say covering the whole of it, are you saying you have an invisible actor? If so, are you setting the alpha to 0, or unchecking "visible" in the wall actor? If this is what you are doing, try changing your method.
  • peachpellenpeachpellen Posts: 977Member
    Deleted the actor, made a new one (exact same - I'd planned to change image types but forgot when saving, lol.)

    Works fine now. Weird, wish I knew why it did it, but I'm pleased :D
This discussion has been closed.