GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Published game on android - players not showing

Hi there

I created a game on Windows and published it to Android. When I open the apk on my phone it is all broken. The players are not visible - good guy, bad guy and buttons. Sometimes I can find where the buttons should be and move forwards a bit but when I get to where there should be a badguy and questions it is all zoomed in on about 2 words of the question. It is completely unplayable.

This is my first Gamesalad project. I am working on something for a group project for school and it needs to be done in the next day or two. I thought I was on schedule but have spent the last 2 days trying to publish and get this to work. Any ideas please? I have googled a lot but can't find anything where people's players etc are not showing.

Thanks for any help.

Comments

  • MentalDonkeyGamesMentalDonkeyGames Posts: 1,276Member
    edited February 2016

    With the very limited info you gave about your project, i'd guess you choose "overscan" when you published and it's hiding a part of your scene. Try publishing again, and choose either "stretch" or "letterbox".

    Overscan is, in my opinion, the best way to go, because it doesn't disort the images, or leave black bars on your screen. However, you need to build your game so that anything important won't get cropped out when overscan is used.

    Mental Donkey Games
    Website - Facebook - Twitter

  • bwcoderbwcoder Posts: 3Member, PRO
    edited February 2016

    Hi Thank you for responding and I'm sorry you're right I didn't give very much information.

    I've checked the settings on the publishing but I had used Stretch. It's not like the screen is distorted, the background is perfectly fine, just the actor isn't there.

    I made this in Windows Creator 1.24. Basically it's a language quiz game. A goody walks along, meets a zombie, has to answer multiple choice questions. The initial logo, start and choose a level screens work fine but then when level 1 starts the background is there but the buttons are not visible. They are actually fully there but just not visible. The goody isn't visible either. If you press where you think the buttons should be you can move forward and you get to the stage where the zombie should be, but then it sort of flashes to a new screen which seems to be zoomed in on the questions but upside down or backwards or something - ie you see something like nse (from tense) upside down and C: but really zoomed in and that's all you see. Can't get any further than that.

    Published for Android, sdk setting 13 and also tried 11, no joy.

    Published on Gamesalad arcade and works fine there - http://arcade.gamesalad.com/games/135861 - so I'm thinking it's something wrong with the Android set up?

  • bwcoderbwcoder Posts: 3Member, PRO

    Just returning to this in case anyone ever has a similar issue. The tech support guys helped us out - it seems like it's not a common thing, seemed like they had to do a bit of digging to figure it out. So, thanks to them!

    Anyway, turns out the background graphic was set on Vertical Wrap - tile, it should have been set to Stretch. As soon as we set it to Stretch then it all worked out.

Sign In or Register to comment.