GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Open URL error?(Pseudo tweetsheet on android)

FrantoFranto Posts: 779Member
edited March 2016 in Working with GS (Mac)

Hi, I've been trying to make a pseudo-tweet sheet for android, I found some examples of possible solutions, but none have worked, here are the results, screenshots taken from my android:


I tried starting with "www." at the start, since http:'// appears in the behavior anyway, I also tried "http://" within the expression editor just to cover all bases. But all I got was what's on the screenshot using the default browser, and if I picked chrome to open in, it would just open the window that was already open, but no page would be opened.

I'm guessing it's due to the address being a "https" when the behavior in creator is set to "http" and the dropdown has the option for https as well. I just caught it now while posting this. I'm guessing that's the problem. I'll have to make the adjustments and test again, but it takes a lot of time to log into the online mac from a PC, so I will do that later.

Comments

  • FrantoFranto Posts: 779Member

    I'm still getting errors like the screenshot, regardless if I use http/https in the dropdown. Or if I start off the url with "www..." or "https..."

    I even pasted the link with quotes in the expression editor, as it was suggested in a thread from a year ago. I used quotes in all instances actually.

    Is the windows version of open url different from the Mac version.

    Does Open URL not work for things like twitter?

    I was attempting to post a twitter message with a score, another example had score, URL to the game on google play, and an image, using a method found on another thread. The last was just message, score, and image. I was thinking that one setup or another might fail, but I couldn't manage to get any to work.

  • FrantoFranto Posts: 779Member
    edited March 2016

    @hopscotch I did mention using that method in the second line of my last post. I opened up the expression editor and pasted it inside on the second round of batch testing.

    I did this on the windows version, I'm gonna try copy and pasting into the expression editor of Mac instead later today.

    EDIT: The screenshot in the second message is from the first batch, but is the example that starts with "www..." string instead of "htt...".

    But perhaps the reason it won't work is because it is a twitter link on an android phone? Perhaps it would work if it was an iphone?

  • MentalDonkeyGamesMentalDonkeyGames Posts: 1,276Member

    I'm not sure, but it might be the attribute you have in the url. Try removing it and see if it works.

    Also, does the link work if you copy/paste it straight in your browser?

    Mental Donkey Games
    Website - Facebook - Twitter

  • GeorgeGSGeorgeGS Posts: 478Key Master, Head Chef, Member, PRO GameSalad Employee

    It looks to me like the problem is with the quotes around the string.

  • HopscotchHopscotch Posts: 2,782Member, PRO

    @Franto

    the url parameters (everything after ?) needs to be escaped.

    So :'s and /'s in the &url section need to be replaced by %3A and %2F

    Also leave out the http:// in the parameters.

  • FrantoFranto Posts: 779Member
    edited March 2016

    @hopscotch Yes, it finally worked, but the examples using "twitter.com..." instead of "www.twitter..." worked, regardless if https or http from the dropdown is used.

    I should have set up more test variables, as the latter two with "www" happened to have the high score value as well. So I can't tell if that caused them to fail or the "www", so I'm about to test that now.

    This is what worked for the initial two, which I was testing http/https for:
    "twitter.com/intent/tweet?text=This is the message&hashtags=hashtag1,hashtag2&url=http%3A%2F%2F pic.twitter.com/wjIKAD8BVz"

    Then the latter two where {EDIT: I just spotted what was wrong with these, gonna test again}

    I'm going back to testing, using the succesful one as the basis to test the highscore and a shortened link.

    Also, soething I have observed, is that the "pic.twitter" to use the image in the pic, works, BUT it appears to use the pinned tweet image of your account, I strongly believe this because the day I found the example in the other thread, when I tested it on the desktop browser, it went to the image that was their pinned tweet.

    Here's what appeared for mine:

    The image I was trying to use:

    The pinned tweet of my account, which happens to have the image in the retweeted tweet:

    I guess the solution to that would be to make an account solely for the image.

    Thought you might want to know.

  • FrantoFranto Posts: 779Member
    edited March 2016

    Ok, I managed to get the score to show up too now. The only thing that this last batch failed with is having a the pic link and google play link at the same time.

    And it appears indeed that for Windows Creator, neither method of input works for Open URL, at least for twitter. What I did was use the same address and paste inside the expression editor from Windows Creator, then went on Mac Creator, and pasted for a seperate open url in the expression editor. The first two are from that test. I just remembered, on the mac, I didn't edit the second of the three that succeeded, I think with Windows, you gotta copy and paste it a certain way, like from a browser, because copying and pasting within the program might lead to the string being empty when you open it in the Mac even though it shows up externally. It's hard to explain, it might just be a copy and paste issue on windows rather than a GS bug, as I noticed some copy and pastes didn't work and just showed up as empty.

    The number refers to the score, depending on the score, a different rule would open up. The last failed as well, but since that one had other different factors, I know at least it has to do with not being pasted in, I didn't get to see if it's other, differentiated variables would cause it to fail.

    0-5 failed
    6-9 worked
    10-25 worked
    26-50 worked
    50+ failed

    Screenshots in the order of the above:




    Results can be seen in the feed on the link:
    https://twitter.com/Fulgryph

    As can be seen, the ones that worked displayed an image but none posted the link that was part of their string. Here are the strings for the ones that succeeded.

    This line is in both the failed and succeeded initial tests of this group:
    "twitter.com/intent/tweet?text=This is the message&hashtags=hashtag1,hashtag2&url=http%3A%2F%2F pic.twitter.com/wjIKAD8BVz"

    This one was the one that showed up in the internal expression editor on Mac after being pasted within the expression editor in Windows, I did the same for the other two, but when I open the expression editor for them on Mac, they showed up as empty, so for two of them, I pasted internally on Mac. I think something is going on with copy and paste on windows as it records it differently depending on where you got it from.
    "twitter.com/intent/tweet?text=My+Hy+Skor+is+".. .."+U+kant+beet+dat!+&hashtags=S00p3rMudmanGold,ISWAGGER&url=http%3A%2F%2F pic.twitter.com/wjIKAD8BVz&url=http%3A%2F%2F http://ow.ly/100mgT"

    This worked, but both the twitter image and the google play link failed.
    "twitter.com/intent/tweet?text=My+Hy+Skor+is+".. .."+U+kant+beet+dat!+&hashtags=S00p3rMudmanGold,ISWAGGER&url=http%3A%2F%2F pic.twitter.com/wjIKAD8BVz&url=http%3A%2F%2F http://ow.ly/100mgT"

    This was the result:

    This failed, but due to copy and paste issues:
    "www.twitter.com/intent/tweet?text=My+Hy+Skor+is+U+kant+beet+dat!+&hashtags=S00p3rMudmanGold,ISWAGGER&url=http%3A%2F%2F pic.twitter.com/wjIKAD8BVz&url=http%3A%2F%2F http://ow.ly/100mgT"

    @GeorgeGS You where right about the quote, there was a double " at the end of some from an earlier test.

    EDIT: After waking up, I see that the ow.ly address still has it's http, I deleted that twice! Somehow it keeps the http after pasting again, really strange. If your on windows creator, and within the expression editor, delete some portions of a string, then copy and paste it, then paste it again, it will paste the original string. D: I have no idea if this is a windows thing or creator thing.

  • FrantoFranto Posts: 779Member

    I figured out that it wasn't the pinned image that takes over, and I got images working now. The only thing I can't do in every test is post both the image and the ow.ly link. Is it not possible to post two URLs when using URL decoding?

Sign In or Register to comment.