GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

game not loading in android

Hi there,

I am very new to gamesalad and i have used the template basic shoot em up to try out.

I ventured further to find out on touch screen control and decided to explore.

i end up using two simple control "up" & "down" with spawning to shoot laser. i published and play the game on my android phone. it works :-)

now i try to add on more buttons "left" & "right" & "fire". But this time the laser spawning is solely on the "fire" button. i tested on preview and it works. so i published it to try on my android phone.

unfortunately, this time i can only see the game loading on my android phone for a while and it just exit.

can anyone enlighten me on this issue ?

thank you for your kind attention

regards,

mok

Comments

  • ka822ka822 Posts: 40Member, PRO

    I am not too sure how you test on android device as I mainly test with iPhones.
    But may be is similar way.

    For Iphone, I use GSviewer to test. Sometimes, it will take 1-2 times to load the project into GSViewer. GSViewer sometimes does not load properly, it might stop if the connection between phone and my mac is not good enough.

    For Android, I do sometimes test on my tablet. And I always publish an apk thru Gamesalad site so that I can download and install to my tablet. Rarely has issue though.

  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,913Member

    Are you using the gamesalad viewer? Make sure you have the most up to date viewer version 1.25.

  • NNterprisesNNterprises Posts: 387Member, PRO

    If you are trying to ad-hoc without the GS Viewer and just downloading your apk, you DO still need to sign it before it can install on your Droid

  • nsaj89nsaj89 Posts: 2Member, PRO

    Hi,

    Thank you for all the replies .. My game is signed and I even tried to restart my phone and also download on several android phone .. still same results .. do not know where to look for solutions ..

  • nsaj89nsaj89 Posts: 2Member, PRO

    I am using another account and using the PRO version .. still get the same results :-(

    Mok

  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,913Member

    Did you install the android SDK? Did you create a keystore? You need a pro account to publish. You must publish through the pro account.

  • mohd_mohtarmohd_mohtar Posts: 2Member

    I have all that done.

Sign In or Register to comment.