GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

still having issues with iap (FML)

Here's the thing...it works on my father's Motorola Droid Maxx but doesn't on my main test device Galaxy Note 4.

on the Droid it pops up the buy prompt and all is good but the buy prompt never pops on the note4 and it automatically lists the item as purchased and gives you the reward.

Comments

  • ArmellineArmelline Posts: 4,718Member, PRO

    There are literally hundreds of reasons why this might be happening. IAP issues are very difficult to figure out without the actual project in front of you. Perhaps strip it down to a template project that includes all the IAP stuff that people can look at.

  • RocketBrainRocketBrain Posts: 269Member, PRO

    So i dumbed down the logic substantially to try to understand how it works. This simple logic works fine on the droid but not on the note 4.

    of note, i put the note 4 into airplane mode, turned off wifi and then ran it. the note 4 still supposedly completed the purchase and even said it was able to successfully fill the tables (such a liar)

    same build, same steps. droid wouldn't let it work. said no connection...

  • ArmellineArmelline Posts: 4,718Member, PRO

    Honestly I'm surprised that would work on either, particularly as you run the Buy before the table is filled by the Request Purchase Data.

  • RocketBrainRocketBrain Posts: 269Member, PRO

    oh right sorry forgot i have a thing separate that has request purchase data

  • RocketBrainRocketBrain Posts: 269Member, PRO

    but that still doesn't explain why the buy request works on one phone but not the other.

  • goonergooner Lancaster, PAPosts: 135Member

    I had a similar problem with purchases and the purchase table status being empty ... It might be different than your situation but just in case it might help ...

    I had typed purchased into the expression editor and it was evaluating as empty string(which is what the status would be for a purchase table that had no wifi) ... Anyway, I clicked the expression editor, hit the clear button, closed expression editor, clicked directly on window, got the blue highlight and typed purchased right in there, after that I at least got that part of my IAP working ... Not sure about different device outcomes but this is what was causing my IAP to be a false purchased.

  • RocketBrainRocketBrain Posts: 269Member, PRO

    @armelline part of why i did this is because your template didn't work on my phone. apparently it worked on the other phone.

  • RocketBrainRocketBrain Posts: 269Member, PRO

    @ellison thanks for your input. i didn't type purchased in anywhere originally.

  • RocketBrainRocketBrain Posts: 269Member, PRO

    Ok so i've gotten the problems narrowed down to android phones on 6.0 Marshmallow. The phones that it works on are 4.4.0 & 5.0

  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,906Member

    @RocketBrain said:
    Ok so i've gotten the problems narrowed down to android phones on 6.0 Marshmallow. The phones that it works on are 4.4.0 & 5.0

    Is you android sdk up to date?

  • RocketBrainRocketBrain Posts: 269Member, PRO

    @The_Gamesalad_Guru yeah it was

    so i woke up this morning and the hail mary fix i threw in last night before bed apparently worked.

    I think the android 6.0+ (marshmallow) requires the productID to be a certain number of characters. I was using "d1", i deleted those and made "packageone" and it worked.

    so all my hours of writing, re-writing, and swearing was wasted. i just had to delete those IDs and make new ones and insert them into the code.

Sign In or Register to comment.