GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Gamesalad won't update HELP!

Im running MacOS 10.12, currently running Gamesalad 1.25.61 trying to update to 1.25.73 but I'm getting this error message:

"An error occurred while extracting the archive. Please try again later."

How do I fix this?

Comments

Sign In or Register to comment.