Gamesalad Viewer reads wrong Table values

eberlepetereberlepeter Member, PRO Posts: 8
edited March 2017 in Tech Support

Hi guys.
In my game I´m using a table for unlocking the different levels.
When I´m using Gamesalad Viewer (Android) to debugg my game, the Viewer reads the wrong values of the table and some levels are unlocked, that should be locked. On the PC everything gets loaded in the right way.
Is it possible, that the viewer loads older versions of my game, or am I doing anything wrong?
I would really appreciate it if you could help me.
Thanks in advance and keep on gaming!


  • pHghostpHghost London, UKMember Posts: 2,302

    Yes. In the viewer, go to 'Recent Games,' then 'Clear List.'

    That should resolve your issues.

    Tables are treated as 'save data' and won't be changed with an update of the latest version of your app, so if you add 4 columns, those won't be there and any logic referring to them will malfunction.

    This can sometimes be confusing, as you might feel you messed up some logic in your game, go through it repeatedly without success, but all you need to do is clear the game away.

    P.S. This also applies when updating published games on the App Stores! If you are doing that, you either need to create an all-new table, or add and fill in rows with data one by one with GS behaviours.

  • eberlepetereberlepeter Member, PRO Posts: 8

    Thanks for the infos.
    I didnt know, that tables are treated as "save data".
    I tried it, but it didn´t work after I deleted the game from recent projects...
    Somehow the old values got loaded no matter what.
    I then created an actor in the startmenu where all the table values are set manually to the values i need them to be for testing ... that worked.
    Many Tanks!
    When I want to publish the game some day I hope i will remember to change it back ;-)
    Thanks for the fast helf again!

Sign In or Register to comment.