Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Admob ads not showing in ad hoc testing

CCBBCCBB Posts: 19Member, PRO

I have set up Google Admob account and all looks fine, however, when I ad hoc test no interstitial ads appear. Is this normal (I was expecting to see placeholder test ads appear)?


  • CCBBCCBB Posts: 19Member, PRO


  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,914Member

    It can take 10 to 20 minutes for ads to appear.

  • pHghostpHghost London, UKPosts: 2,301Member

    If you are doing ad-hoc testing of a dev version (so a testing, it should give you a placeholder, I think. Did you tick any Ad Services during publishing? Do they show up in GS Viewer testing?

  • CCBBCCBB Posts: 19Member, PRO

    I have tried everything but still not getting Admob interstitial ads showing in adhoc publishing. Does anyone know if I should be seeing placeholder ads or do the ads only show when game is fully published?

  • ToqueToque Posts: 1,182Member

    Adhoc adds should show in adhoc testing.

    There were times it wouldn't show up in adhoc. I would make a new admob campaign and use the new number in GS publishing.

    Make sure you use the right number.
    Click admob interstitials on.

    I've had problems with videos. I don't use them.

  • CCBBCCBB Posts: 19Member, PRO

    Thanks Toque.

    I will try the new number thing, appreciate the advice :wink:

Sign In or Register to comment.