GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

URGENT -- App Rejected -- In-App Purchases Not Working

pHghostpHghost London, UKPosts: 2,289Member

Just got an app rejection from Apple, the reason being that in-app purchase buttons aren't doing anything.

Publishing from 1.25.80, macOS Sierra, build generated yesterday.

The logic for in-app purchases is 100% identical to all projects I've worked on (apart from unique IDs; triple checked that they correspond), never had a problem before.

Fired up the ad-hoc and got the same issue as Apple. When you press any in-app button, the button press sound plays, but no purchase request. Restore Purchases on the other hand brings up the system dialog without issue.

When testing in Creator Preview and pressing the button, everything seems to be working, I get the regular notification that a purchase request has been sent, but the behaviour isn't supported in the Viewer. What gives?

Anyone seeing the same issue?

@adent42 is this a known problem? Trying to get this game on the app store before the holiday break.

Comments

  • glentritchieglentritchie Posts: 2Member, PRO

    I have the same problem today and yesterday so I decide to remove the IAP to get the approval and latter try to solve this problem

  • JoeBJoeB Posts: 160Member

    I've also noticed this, is this is an issue with gamesalad at the moment?

  • AdrenalineAdrenaline Posts: 523Member

    Jeez, it's one thing after another lately...

  • pHghostpHghost London, UKPosts: 2,289Member

    @adent42 can you please let us know if you are aware of this issue, and whether it is a publishing portal issue or a Creator issue? Clearly I’m not the only one experiencing this, so it doesn’t seem related to the particular project.

    I’m willing to update to High Sierra and 1.25.83 if that solves the problem.

  • glentritchieglentritchie Posts: 2Member, PRO

    I am in high Sierra, and still with the problem

  • JoeBJoeB Posts: 160Member

    Anyone? I've released many apps with a ton of in apps and I cant seem to get this one working

  • pHghostpHghost London, UKPosts: 2,289Member

    Same here. I sent @adent42 a sample file, so hopefully he will get back to us on this soon.

  • adent42adent42 Posts: 1,226Key Master, Head Chef, Executive Chef, Member, PRO GameSalad Employee

    Heya... I've been chatting directly with @pHghost about this problem... We can't reproduce over here. But we've been testing in the sandbox.

    So right after the first release we did a patch, so you had republish to get the fixes.

    1) Did you test on sandbox
    2) Did you know about the patch after the first iOS 11 release. Sadly hadn't seen this thread so I only announced in the state of GS thread.

    PM me a link to your publishing page if you're still having problems after sandbox testing and we can look into it.

  • JoeBJoeB Posts: 160Member

    I tried creating a new sandbox user account, and it started working after a while

  • pHghostpHghost London, UKPosts: 2,289Member

    So, for anyone experiencing similar problems:

    What happened was that this game was being published on a new Apple Dev account and the tax, banking etc. information wasn't filled out.

    Still, for some reason, Apple not only let us submit the app for review but then after rejection they simply stated that there is a problem with the app itself which needs to be fixed. No notification that anything is missing on iTunes Connect. Basically, entirely confusing and misleading on Apple's side...

  • pHghostpHghost London, UKPosts: 2,289Member

    This means IAP are actually working as they should, thank God!

Sign In or Register to comment.