GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Signing in Adhoc doesn't Work

So I'm in the in-app menu for my app, and whenever I try to purchase an in-app and sign in into a sandbox account, it just keeps asking for me to sign in and nothing gets purchased. Is this is an issue with gamesalad?

Comments

  • pHghostpHghost London, UKPosts: 2,289Member

    Have you set up the SandBox account in iTunes Connect?

  • JoeBJoeB Posts: 160Member

    Yes, I've used that account for other apps in the past and they've worked. It just keeps asking me to sign in, i enter my username and password, and then the prompt appears again @pHghost

  • JoeBJoeB Posts: 160Member

    I can confirm that this is not an issue with my project, as I tried it on an adhoc build of an already released project and it was doing the same thing. Can this be fixed please as the holiday season is approaching

  • pHghostpHghost London, UKPosts: 2,289Member
    edited December 2017

    You don’t need to test it with the SandBox user. Haven’t done that for a couple years.

    Bigger problem is that currently IAPs don’t work at all, for some reason. The two might be related.

    @adent42 is hopefully looking into it.

  • JoeBJoeB Posts: 160Member

    How do you test it then? When I use the viewer the purchase request comes through, but nothing happens when i use an adhoc build

  • pHghostpHghost London, UKPosts: 2,289Member

    I normally don't test IAP at all -- just trust it's going to work. Which it always has before.

Sign In or Register to comment.