Gamesalad fails to install/start windows 10 version 1709 os build 16299.125

scottwoodscottwood Member, PRO Posts: 68
edited December 2017 in Tech Support

Just tried to install Gamesalad for the first time and nothing seems to work. The installer fails to install anything. The exe download seems to installs something but the program fails to open.


  • scottwoodscottwood Member, PRO Posts: 68

    Uninstalling / Restarting etc failed to work - until I uninstalled with a 3rd party uninstaller (Revo). Seems to be all working now. Finger crossed....

  • scottwoodscottwood Member, PRO Posts: 68

    Guess I spoke to soon. Gamesalad started after it was installed and seemed to work fine, I worked through the first tutorial with no problems and closed everything down. Now it fails to start, just like before. It's as though the icon to start the program is linked to a blank file, nothing happens when it is clicked. I tried going to the application folder and using the exe file there, but that has the same results. Is this a common problem with Gamesalad on PC - or it just my machine?

  • scottwoodscottwood Member, PRO Posts: 68

    Sorted. Antivirus software had taken exception to gamesalad. Added an exception rule and it's started working.

Sign In or Register to comment.