GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Buttons not detecting touch correctly

I'm experiencing a weird issue that only occurs when I run an ad-hoc test on an IOS device. On android devices my game is running with new issue and I've run ad-hoc tests on more than one IOS device so I know it's not a unique issue.

Whenever a user tries to tap "menu" and "reset" buttons I have on the top of the screen the touch isn't being detected when the actor its self is being tapped. It seems to only detect user input when they tap the area below where the actor actually is.

The issue makes my game appear quite sloppy and buggy so I'd really appreciate any solutions you guys have.

Comments

  • ToqueToque Posts: 1,166Member
    edited January 27

    Are buttons near edge of screen?? There’s a bug with buttons near edge

  • RowdyPantsRowdyPants Posts: 410Member, PRO

    @mallenmatt64 There used to be a bug where the detect display size would not work correctly on android at the first couple seconds of loading the app.

    Might can try placing/moving your buttons again after a delay (even to the same spot) if you're moving them based on the display size.

  • ZwireZwire Posts: 165Member, BASIC

    This is a bug and affecting my game also. GS staff is "testing" it. But dont expect a solution soon.

  • JapsterJapster Posts: 646Member, PRO

    @Zwire said:
    This is a bug and affecting my game also. GS staff is "testing" it. But dont expect a solution soon.

    Well, Alex / @ForumNinja has advised me that they are, so fingers crossed mate... Here's hoping they sort it very soon....

  • ZwireZwire Posts: 165Member, BASIC

    I dont know Japster. Spoke to him a week ago and he said he was looking into it but he doesnt react anymore.

    When did you have contact with him?

  • JapsterJapster Posts: 646Member, PRO

    @Zwire said:
    I dont know Japster. Spoke to him a week ago and he said he was looking into it but he doesnt react anymore.

    When did you have contact with him?

    The 25th, mate - here's hoping they're getting somewhere, I'm just awaiting an update from him, as he said he'll let me know when he has further updates... Not heard anything yet though...

  • ZwireZwire Posts: 165Member, BASIC

    Got a message from him today saying that he can reproduce the problem . Sent me a test project so I can test it with my configurations.

    This seems to affect a lot of people so dont know why I have to test it. Dont get why the developers just dont jump on the problem and test for themselves.

    Have a feeling this will take months before it gets solved.

  • pHghostpHghost London, UKPosts: 2,283Member
    edited January 30

    They have been able to reproduce this problem for about a year or so now... I discussed this with them long before it became a big issue for everyone.

    Sadly, it still hasn’t been fixed. At least it seems they are now paying more attention to it, with more people complaining.

Sign In or Register to comment.