Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Ad Mob/Rev Mob not displaying in Ad Hoc

Ok, so like the title says, neither Ad or Rev Mob are working for me when I ad Hoc load my game to my iPhone. Ive tried both with banners and interstitials (preferred) and neither are working so I don't think its their end, must be something Im doing wrong, but Ive watched several videos and searched google and everything Ive found Ive done... None of it is working.

In the game I have a 'replay' actor with a scene change back to that scene after reseting game over and score. That scene change is marked with an interstitial.

On the web once uploaded I have tried both ad and rev mobs with their IDs pasted into the services area, triple checking that I have marked the same ad type (banner/interstitial) depending on what code Im testing this time.

I clicked the box to communicate insecurily (sic)

I then generate, sign with my ad hoc cert, load to my phone Xcode.... and nothing... no interstitials when thats turned to on, no banners when thats set to on....

Any ideas?


  • pHghostpHghost London, UKPosts: 2,282Member

    Are you using the correct bundle identifier?

  • rodberubeerodberubee Posts: 3Member, PRO

    I saw Bundle Identifier on Rev Mob, its N/A and I can't figure out how to edit it, but I dont see a bundle identifier in ad mob or in iTunesConnect

  • pHghostpHghost London, UKPosts: 2,282Member

    Bundle Identifier = Bundle ID in iTunes Connect. Every app must have one. You cannot add an app in iTunes Connect without setting a Bundle ID.

    Seems like you don't need it in AdMob And RevMob.

    By the sounds of it, your RevMob isn't active yet. Are you running test ads?

  • rodberubeerodberubee Posts: 3Member, PRO

    Yeah it hasn't gone live yet in RevMob, so it only sends test ads. I'll look for the bundle ID here in a few minutes

Sign In or Register to comment.