State of the Salad 06/2018

13»

Comments

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 1,787

    @AlchimiaStudios @strag unfortunately not.

    I think it's going to be better for some of the errors, but I have finally been able to reproduce a bug based on a particular back button pattern (vs the home button, which is what I've been testing with).

    I'm trying to work out if it's possible to fix the loading image issues, but I think we may be at a point we'll need to enforce square loading images. Anyway, I found the sound issues while trying to test loading screens, so hopefully the next RC will have some fixes for both issues.

  • MusicBoutiqueMusicBoutique Member, PRO Posts: 115

    @adent42 said:

    I think it's going to be better for some of the errors, but I have finally been able to reproduce a bug based on a particular back button pattern (vs the home button, which is what I've been testing with).

    I'm trying to work out if it's possible to fix the loading image issues, but I think we may be at a point we'll need to enforce square loading images. Anyway, I found the sound issues while trying to test loading screens, so hopefully the next RC will have some fixes for both issues.

    Nice one!

  • stragstrag Member, PRO Posts: 587
    edited September 2018

    @adent42 thanks for the update.

    Glad you were able to replicate the bug with the back button and hope you manage to crush it soon.

    (Update; just tested with the Build RC, the crashing issue seems to be resolved on my device although unfortunately I'm now missing all sound FX! )

  • ArmellineArmelline Member, PRO Posts: 4,918

    @adent42 You can no longer double click on an image to open it in Finder. This is particularly important when names are long and getting truncated.

    That's the only issue I've found so far. The image list is a bit slow to load sometimes but nothing major.

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 1,787
    edited September 2018

    FYI, I'm not able to fix the loading image as I was expecting to, so I will be adding some options that will make the loading image more flexible:

    1. No set sizes. Put in whatever you want. We won't be scaling the image, just displaying it . Our 'official' suggestion is now to upload a square image that will look good in either orientation. Basically, outside of our control and unexpectedly, the OS can swap from landscape to portrait momentarily during load. If your image is a square in the middle, it will always look good in any orientation.
    2. You will be able to define the target DPI of the image and we will scale the image so that it looks about the same size on all devices.
    3. You will now be able to define a background color in case your image is smaller than the display size. You can have your image blend with the background OR you could make a small loading image and pick a complementary color (like having a small icon in the middle of the screen or something with transparency).
    4. You will now be able to specify if your image is a 9-patch image. Google it for details, but the TL;DR is that it's a format that will stretch the edges of your image while keeping the center of the image correct. This will allow you to center an image and stretch it's edge to whatever the screen size is.

    I'll let you guys know when this is finished, but that's what I'm working on now and hope to have it out soon.

  • HypnorabbitHypnorabbit SingaporeMember Posts: 210

    Hey @adent42 thanks for the update. Do you have any ETA on Google play services yet?

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 1,787
    edited September 2018

    @Hypnorabbit sorry, the loading image thing became a rabbit hole (no pun intended). I expected it to take a day and it's been about a week figuring this all out. So it's pushed off Google play services more than expected. No ETA, but the current order of priority is:

    • Finish up this loading image work for android.
    • Track down an issue with sound on android (related necessary upgrade of OpenAL and to fix the WAIT_LOCK issue).
    • Enable all Admob ad types at once.
    • Google Play services.

    I originally had the Google Play services before the Admob stuff, but because of a couple of back and forth switches we made during the Great Ad Network Upgrade, my google play code is now out of date, so it would be faster to get the Admob stuff done first.

  • DigiChainDigiChain Member, PRO Posts: 1,216

    @adent42 said:

    • Enable all Admob ad types at once.

    This I am excited about!

  • HypnorabbitHypnorabbit SingaporeMember Posts: 210

    @adent42 said:
    @Hypnorabbit sorry, the loading image thing became a rabbit hole (no pun intended).

    Dear lord.

    Sounds great can't wait for the release, especially Admob.

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 1,787

    So that's not all coming in one release, it's more an order of priority. I'm thinking it will be: Androind sound and loading. Then an admob release. Then a Google Play services release.

    There might be a change in admob releas

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 1,787

    So... kind of no? The current RC doesn't play sound in most cases, so no crashes related to sound issues!

    I'm not sure why yet, so that's what I'm tracking down this week.

    Basically it works fine when I do a "debug" build, but the sound goes away in a "release" build (but not all the time). I'm hoping it's something stupid like me putting a debug flag in the wrong place somewhere, but it's gonna take some time to figure it all out.

  • freneticzfreneticz SwedenMember, PRO Posts: 722

    Yeah i tried a build today where there is no sound, i have a sound on/off button in main menu and when i touch it to change off on off on i also see a bigger with low alpha "sound on/off" to the left of the real text

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 1,787

    @CasualEvolution I moved your question and my response into their own thread, since it seemed worthy of it's own discussion.

    https://forums.gamesalad.com/discussion/96803/help-google-play-store-feedback-for-getting-featured

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 1,787

    I think I may have finally cracked the no-sound problem. There's still some more testing to do, but if we're lucky, there will be a new RC build out before the end of the week.

  • bob loblawbob loblaw Member, PRO Posts: 531

    @adent42 said:
    I think I may have finally cracked the no-sound problem. There's still some more testing to do, but if we're lucky, there will be a new RC build out before the end of the week.

    did you turn it off and back on again?

  • bob loblawbob loblaw Member, PRO Posts: 531

    disappearing image panel when going between large scenes seems to be working on the latest version. thanks for fixing.

  • HypnorabbitHypnorabbit SingaporeMember Posts: 210
    edited October 2018

    Wrong thread oops.

Sign In or Register to comment.