Background Image?

So, I've made an actor to act as my background image. However, when the image is in the scene, my character can no longer move. Why could this be?

Thanks in advance.

Comments

  • VGXVGX Member Posts: 796
    edited January 2014
    You may have gone wrong in your rules somewhere, try downloading some free templates so you can have a look at how others do it and you can compare your rules to theirs and see what you are missing and perhaps done wrong -
    http://www.deepblueapps.com/
    http://forums.gamesalad.com/discussion/52494/spare-code-dump-it-here/p1

  • ReMasteredGamesReMasteredGames Member Posts: 101
    You may have gone wrong in your rules somewhere, try downloading some free templates so you can have a look at how others do it and you can compare your rules to theirs and see what you are missing and perhaps done wrong -
    http://www.deepblueapps.com/
    http://forums.gamesalad.com/discussion/52494/spare-code-dump-it-here/p1

    I just had a look at a few templates. My images settings and rules are identical. I'm not sure what's wrong
  • tatiangtatiang Member, Sous Chef, PRO, Senior Sous-Chef Posts: 11,928
    Why could this be?
    You're asking us to guess about something that is caused by the way you have your rules (or possibly your layers) set up and you haven't given us any information about your rules. Either post a screenshot or a link to download your project file and we'll go from there.

    Another thing to try is to create a new blank scene and add your "movement" actor to it. Is the actor able to move? If so, add the background image actor. Is the actor able to move now?

    New to GameSalad? (FAQs)   |   Tutorials   |   Templates   |   Greenleaf Games   |   Educator & Certified GameSalad User

  • ReMasteredGamesReMasteredGames Member Posts: 101

    Here is a link to my project.

    https://www.mediafire.com/?2i36ctymw8aoixd

    When creating a blank scene, I sent the background to the back, and in the editor it looked fine. Yet when previewing, the background was in front of the character.

    Also I can't seem to rename it, I used a GS recipe as my basis for the character's movement and just stuck with that file. (PS, I am using Windows Creator)
    Thank you
Sign In or Register to comment.