Every GSviewer app has worked on my iPod except 8.7 - please help!

scitunesscitunes Member, Sous Chef Posts: 4,047
edited November -1 in Tech Support
I am signing it with an adhoc, which I have done in the past. I even made a new adhoc provisioning profile. It starts to build it (even says "successful" at the bottom) and then I get a window that opens that says:

"The executable was signed with invalid entitlements.

The entitlements specified in your application’s Code Signing Entitlements file do not match those specified in your provisioning profile."

I changed the info.plist like always. I just did this with my iPad and it worked fine. What I am I doing wrong?


  • quantumsheepquantumsheep Member, PRO Posts: 8,188
    Is your ipod firmware up to date?

    I had a similar problem where it wouldn't let me put the viewer onto my ipod. I changed the 'release' info to '3.1 Release' and it worked. I'd previously had it set to 3.2 for my iPhone, and I'd obviously not updated the iPod.

    Make sense? Give it a go! And good luck!

    QS :D

    Dr. Sam Beckett never returned home...
    Twitter: https://twitter.com/Quantum_Sheep
    Web: https://quantumsheep.itch.io

  • scitunesscitunes Member, Sous Chef Posts: 4,047
    Thanks, QS. But that didn't seem to be the problem. I think Bill Gates designed Xcode - I never understand any of the errors that pop up.
  • CodeMonkeyCodeMonkey Head Chef, Member, PRO Posts: 1,803
    Try deleting the provisioning profiles from your ipod and reinstall.
  • iDeveloperziDeveloperz Member Posts: 1,169
    Go on I know a bit of Xcode. What you need to do is change the.plist file to

    com.scitunes.myapp ... whatever instead of com.gendaigames.gamesalad

    Then check in the project settings that it is set with the correct developer bundle settings. And make sure the OS version is correct.

  • scitunesscitunes Member, Sous Chef Posts: 4,047
    yeah, did all that. still no dice
  • scitunesscitunes Member, Sous Chef Posts: 4,047
    just updated iPod to 4.0 and downloaded newest xcode - we'll see...
  • HunnenkoenigHunnenkoenig Member Posts: 1,173
    The same here.

    Now I can't even reinstall 0.8.6

    I didn't need a distribution provision, but a development provision.
    Now it works
  • scitunesscitunes Member, Sous Chef Posts: 4,047
    getting 4.0 and the new xcode worked for me
  • HunnenkoenigHunnenkoenig Member Posts: 1,173
    Oh, ok.

    I edited my above post. I needed a development provision not a distribution provision.
Sign In or Register to comment.