Android.apk Sign Error in RC 0.12.9, RC 0.12.8, RC 0.12.6 on Yosemite

RowdyPantsRowdyPants Member Posts: 465

GS keeps getting stuck right at the last step of the android app signing process. 'Select output location' window is not showing destination folders and the 'Next' button is unclick-able. Is it a Yosemite thing? I republished with the three newest RCs and all of them keep getting stuck here. I tried Safari and Chrome. Am I missing something obvious? Is it a Java thing? The Mac OS doesn't come bundled with Java any more so after grabbing Yosemite I went back and re-downloaded Java 8 and 7 and both JDKs.


  • BlackCloakGSBlackCloakGS Member, PRO Posts: 2,250
    edited October 2014

    Try java 6 i have very bad luck with Java 7 and up when it come to android signing. Unfortunately android uses java tools (not controlled by google ) to sign android apps.
    So they change with every version of Java

  • QASaladQASalad Inactive, Chef Emeritus Posts: 142

    I linked it in your bug but I'll link it here as well in case other people have the same issue. You need JRE 6 (java version 1.6.0_65) for Android signing.

    Download from here:

  • RowdyPantsRowdyPants Member Posts: 465
    edited October 2014

    @BlackCloakGS @QA Salad Thank you. I was hoping that would fix it but something is still not happy. I removed 8 and 7 (JDKs, JRE plugins, prefpanes) and got that Apple version but GS is still getting stuck. My android SDK and adb are updated. I know java can be finicky and even display one version but actually be using components of another. Any other tricks for me?

    It looks like there is a new 'Android Studio Beta with SDK for Mac' available. I'll try it out and get back.

  • QASaladQASalad Inactive, Chef Emeritus Posts: 142

    Not sure what steps you took to remove Java but try this:

    To uninstall the JRE, you must have Administrator privileges and execute the remove commands either as root or by using the sudo(8) tool.

    Remove one directory and one file (a symlink), as follows:

    Navigate to /Library/Internet Plug-Ins and remove the JavaAppletPlugin.plugin directory

    Navigate to /Library/PreferencePanes and remove JavaControlPanel.prefpane

    Do not attempt to uninstall Java by removing the Java tools from /usr/bin. This directory is part of the system software and any changes will be reset by Apple the next time you perform an update of the OS.

  • RowdyPantsRowdyPants Member Posts: 465
    edited October 2014

    Yea. Those look like the Oracle instructions. Don't worry, I used terminal and did it 'correctly'. I verified by looking in all the frameworks folders to be sure the system was really using 1.6 as its current JRE and JDK and that 1.7 and 1.8 weren't sneakily hiding. As soon as this new Android Studio Beta software updates I'll retry the sign process with the updated build tools.

    EDIT: Grr. Perpetual stuck-ness. I pointed GS to the 'zipalign' in the Studio Beta folders and that didn't seem to change much. I'm using the standard jarsigner and keytool executables. Are there any other java related processes I can try? I guess I'll just have to manually sign my .apk with Eclipse and terminal? I don't know what else to try :(

  • RowdyPantsRowdyPants Member Posts: 465
    edited October 2014

    I'm sending GS to tools (jarsigner and keytool) that I'm sure are 1.6. I still can't get past the window above. I'm reading that it's possible to sign a .apk with 1.7 if you change your algorithm to SHA-256. Is it alright if I do that? I'm very new to everything android related. If that is okay I'm gonna try to sign it that way. I'm probably doing extra and unnecessary work but I can't get 1.6 java to cooperate. Before that though, with 1.6, should I try making a keystore with DSA instead of RSA?

  • jigglybeanjigglybean Member Posts: 1,584

    I had to update to Java 8 and everything worked out fine. I spent ages scratching my head and wasnt sure if it would work, but it did.

    Like Balls? Then click here! We've 100 coming soon

  • RowdyPantsRowdyPants Member Posts: 465

    I think I'm cursed, guys. I tried every version combination of keytool, jarsigner, & zipalign.

  • iKlazzyiKlazzy Member, PRO Posts: 71

    @RowdyPants said:
    I think I'm cursed, guys. I tried every version combination of keytool, jarsigner, & zipalign.

    I myself am having problems with Java 8/Yosemite

    'Android code signing error' saying my password is incorrect for the keystore, although I just compiled the apk on mavericks about an hour prior no problem. I don't get it. I am kind of mad I updated

  • EclipseGamersEclipseGamers Member, PRO Posts: 91

    i am also getting this!!!!

  • RowdyPantsRowdyPants Member Posts: 465
    edited November 2014

    @jigglybean‌ I'm going to try and follow in your footsteps. Can you tell me which version (exactly - 1.8.x.x) you're using of java. And which version of GS you're using to sign. And, just to be sure, can you tell me the sizes (55k, 99k, 108k, etc.) of your keytool, jarsigner, and zipalign files.

  • RowdyPantsRowdyPants Member Posts: 465

    It magically started working! Recently updating GameSalad seemed to solve it.

    GameSalad version 0.13.26 beta + Java 1.8 = Happy Android

Sign In or Register to comment.