upgrade to snow leopard and GS 8.7 glitch

rdcuberdcube Member Posts: 361
edited November -1 in Tech Support
I've been out of iphone game development for a while and only tinkering with GS every now and then (been busy at day job).

Now due to iPhone 4 and iOS 4, I upgraded my leopard to snow leopard.
I have also downloaded GS 8.7.

Some how, some of my old games are now messed up; meaning, when I open some of the prototypes I was working on, all images disappeared; I found a post from TSB about opening the packages from the file and made sure all images were there...they were all there, but still no luck...the only fix was to re-replace all images.

After I opened the file in question again, every time I import additional images and/or make changes to the project file, all images come in super tiny and/or blurred; I have to enable the stretch option and it all still looks blurry. I made sure that my images were at the 'power of 2', but some how, I still have 'trailing' digits (ie. 32.0456 x 24.0089). Images are png - 72dpi.

I removed GS from the mac, re-downloaded and re-installed the app again to no success.

I created a blank new project and imported a random image and it still does the same thing.

My prototype file now seems useless since I can't continue working on it at all due to these discrepancies.

I'm afraid of opening my previous games for updates (since I heard that the loading time is faster)...I just don't want to get corrupted files again (even though I have several backups of them).

Again, all was working prior to 8.7 and snow leopard.

Anybody has run into something similar and/or any suggestions to my dilemma?


  • rdcuberdcube Member Posts: 361
    I just lost all my work :(
  • rdcuberdcube Member Posts: 361
    hmmm...well, I got the iphone4 and now I'm in a new pickle...none of my 'dev' profile games and/or GS viewer loads on it.

    I added the device on to my profiles/certs for each game.

    Do I need to rebuild/resubmit for publishing on GS?
    Do I need to get Xcode 3.2 and recompile?

    eitherway, still my GS project is all messed up on my mac, even if I open from an old backup...any change, always messes up all images :(

    any feedback will be highly appreciated. thx!
  • hrsmediahrsmedia Member Posts: 522
    I don't know if you have to create new provisioning profiles for your games with the new SDK and then rebuild them? Might be wrong, just a suggestion.
  • rdcuberdcube Member Posts: 361
    I've tried a couple things already an no luck.
    sorry to keep bumping this again...if somebody tells me I'm SOL, I'll stop and wait for next GS update and see if all goes back to normal.

  • rdcuberdcube Member Posts: 361
    I'm noticing that none of the 'recent projects' are loaded at all and/or never stay in the list either.
    Also, whenever I create a new project and import images (even from the old games I had published before) seemed to scale/import correctly. They must be set to 'stretch' otherwise, they always stay 'tiny'.

    I re-re-downloaded GS 8.7 and still no luck.

    Any suggestions? Anybody?

  • rdcuberdcube Member Posts: 361
    I just created a new png image, 480x320 to test and when I imported it to GS, the image is 315x125...wtf?

    I'm really worry and running out of ideas on how to keep working with this

  • VoidedSkyVoidedSky Member Posts: 1,095
    have you tried deleting the gs files in the Library?
  • VoidedSkyVoidedSky Member Posts: 1,095
    Sorry double post
    Sorry double post
    lol ;-)
  • CodeMonkeyCodeMonkey Member, PRO, Chef Emeritus Posts: 1,803
    rdcube said:
    I just created a new png image, 480x320 to test and when I imported it to GS, the image is 315x125...wtf?

    I'm really worry and running out of ideas on how to keep working with this


    So opening the file in Preview shows the original file as 480x320 at 72dpi? Then dragging that file into the image assets media pane somehow modifies the size of the image as shown if you drag that image to the actor prototypes area to create a new actor at the size of the image?
  • rdcuberdcube Member Posts: 361
    Hi Codemonkey,
    Print preview doesn't show the correct size either.
    can I send you the file with the images I'm trying to use and see if you can replicate? if so, where to?

    @cowtechman, the only file on library is 'gs license'.

    Just reiterating that all was working fine until I upgraded to snow leopard and downloaded GS 8.7
  • firemaplegamesfiremaplegames Member Posts: 3,211
    If you want to send me the image, I will confirm that it is saved correctly.

    joe at firemaplegames dot com

    I upgraded to Snow Leopard a few months ago and haven't noticed any issues at all...
  • firemaplegamesfiremaplegames Member Posts: 3,211
    I responded to your email. Here it is in case anybody else runs into it:

    Hey Raul!

    So the problem is that those images have a resolution of 182.88 ppi, not 72 ppi.

    That is why they are coming in so small.

    Do you have Photoshop?
    If so, you can open the Image Size dialog under the Image menu.

    In that dialog, uncheck the "Resample Image:" checkbox in the lower-left corner.
    Then change the resolution to 72 ppi.

    That will just change the resolution without changing the artwork in any way.

    You will need to do that for every image, but at least you don't have to recreate them all from scratch!

    Going forward, make sure that any new graphic you create has the resolution set to 72 correctly before you begin.

    Hope this helps!
  • rdcuberdcube Member Posts: 361
    Hi Joe,
    I got your email and replied back as well.

    I don't use photoshop, I use Fireworks, the default ppi is always 72. All was working before I upgraded to 8.7 an snow leopard, those were the exact same images I had before all these mess.

    The work around I have to do to get things working will be a pain until I get and learn PS (mainly export from FW and opening and exporting from PS by unchecking that resampling box or export to web/idevice)...hey, at least that gets me moving forward again.

    Thanks again!
Sign In or Register to comment.