Joystick controlled actor do not collide properly with "floor".

My joystick controlled actor goes through the floor after collision. Dont know how to fix this, please help.
I've attached the demo file if someone could take a quick look, I would really appreciate it :)

Comments

  • GreenfroggGamesGreenfroggGames Member Posts: 224

    @Socks maybe you have a solution to this one, need some brilliance :wink:

  • SocksSocks London, UK.Member Posts: 12,822

    I'm not sure what the issue is, the actor 'player' didn't go through the floor (the lower 'wall' actor) when I previewed the project ?

    The Move Controller's movement was very strange, it was much better after deleting the Offset Constrain actor.

  • ArmellineArmelline Member, PRO Posts: 4,917

    @GreenfroggGames I agree with @Socks about the movement. That Offset Constrain actor shouldn't be necessary. You know the offset from the camera re-sizer actor, it shouldn't be necessary to have a separate offset attribute. I'll really try to get around to looking at the whole scrollable/universal issue soon.

    To fix your current problem, though, try enabling "Better collisions" in the player actor.

  • GreenfroggGamesGreenfroggGames Member Posts: 224

    @Socks It's fine when the actor rotation is at 90 or 270. But at let's say 120 degrees and moving down/left to right (or right to left) across the floor, the actor goes through a bit. @Armelline yeah that offset is wrong, forgot to change that. Better collisions didn't do anything I'm afraid :(

  • GreenfroggGamesGreenfroggGames Member Posts: 224

    Is it possible that the rotation constrain is causing the collide behavior to not work properly? Is there a a workaround the constrain rotation behavior?

  • SocksSocks London, UK.Member Posts: 12,822

    @GreenfroggGames said:
    Is it possible that the rotation constrain is causing the collide behavior to not work properly? Is there a a workaround the constrain rotation behavior?

    How do you want the player actor to rotate ?

  • GreenfroggGamesGreenfroggGames Member Posts: 224

    @Socks if the controlled actor was a ship, I want it to rotate so that its nose always points in the same direction as the joystick is pointed

  • SocksSocks London, UK.Member Posts: 12,822

    @GreenfroggGames said:
    @Socks if the controlled actor was a ship . . .

    A ship ? As in a boat ?

  • SocksSocks London, UK.Member Posts: 12,822

    Rotate to Angle:

    Angle: game.controller rotation center -90

    Speed: 500

    Relative to Actor

    RTC and SOD = off (unchecked)

  • GreenfroggGamesGreenfroggGames Member Posts: 224

    @Socks I was thinking about a spaceship but its not important, a boat will do:) > @Socks said:

    Rotate to Angle:

    Angle: game.controller rotation center -90

    Speed: 500

    Relative to Actor

    RTC and SOD = off (unchecked)

    This only works when rotating CCW, when rotating CW it starts to twitch.

  • SocksSocks London, UK.Member Posts: 12,822

    @GreenfroggGames said:
    This only works when rotating CCW, when rotating CW it starts to twitch.

    It worked fine for me.

  • GreenfroggGamesGreenfroggGames Member Posts: 224

    @Socks Mine is ok as long as I rotate the joystick slowly, when I move it faster it's like it gets stuck

  • GreenfroggGamesGreenfroggGames Member Posts: 224

    @Socks I restarted GS and now it works! Thanks

Sign In or Register to comment.