Mac GS vs PC GS

I wrote a tone of stuff from 2012 to 2014ish using Mac GS. And then i stopped. Now that i go back, alot of the stuff won't open in Mac GS but opens just fine in PC GS plus they seem faster on the PC side. Are there any bad reasons not to just switch to windows (reasons other then Windows is crap) and go from there?


  • Game On InteractiveGame On Interactive Member, PRO Posts: 37

    Windows works efficiently, Thats What I use and prefer to use to Lay out my Game, as it's much easier to place actors and visually move them to the exact coords you need. Overall though for the rest of the process GS on Mac seems to be the better choice, just easier to get the code you need and everything runs smoother in my experience.

  • TapcodiaTapcodia Member Posts: 84

    So i tried publishing from the PC and it says to download the latest GS, but i already have it. Also, will i still be able to publish to the iPad from the PC. I would still have my Mac, but if i can't open this project on the Mac, will i still be able to build it on a Mac (one i get my dev certs etc... all lined up)? I haven't published with GS since 2014 so things are a little different.

  • Twayne2Twayne2 Member Posts: 458
    edited June 2018

    That's a weird glitch.

  • TapcodiaTapcodia Member Posts: 84

    I tried opening my Mac project on several other macs running various versions of MacOS and same problem. GS attempts to open it, and then the CPU usage goes to 100% and never opens. I open the same exact project on Windows and it opens it in seconds. I have tried removing all images, sounds. Removing actors and or scenes in Windows and exporting for mac but no luck. Just won't open. I wouldn't mind using the PC but it won't publish because i need the latest GS, which i already have installed so GS is confused.

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 1,927

    @Tapcodia try re-saving the project in PC and seeing if it works. I'd try re-saving and opening first. If that doesn't work, ping support chat and see if they can kind the issue and fix the games.

  • TapcodiaTapcodia Member Posts: 84

    Oh, i . tried that. I tried resaving, exporting, remove actors/images/sounds etc.
    However, i found the problem. I had a set of attributes and i made a dummy one kinda as a separator before the next set of attributes. This worked fine in the older ( 2013 ) versions of creator. It also worked fine in the newest PC creator but not the newest Mac Creator. The attribute name was "----------" i removed this attribute and it opened just fine. Im not sure if it was because i had a bunch of hyphens or if a single hyphen would cause the same problem. I just know i removed it using the PC creator, exported it, and the mac creator opened it up just fine.

Sign In or Register to comment.