GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Apple Discontinued Application Loader from Xcode 11

jinedjined Posts: 42Member, PRO
edited September 21 in Working with GS (Mac)

Since XCODE 11 released, Apple discontinued the Application Loader, allowing to upload apps through directly Archive organizer into XCode development framework.

Here a bypass to keep uploading products realized with external development engines.

1) OPEN TERMINAL
2) CD TO THE PATH OF CURRENT .IPA GENERATED BY GAMESALAD
3) SEND THE FOLLOWING LINE COMMAND

xcrun altool --upload-app -f "gamesaladbuild.ipa" -u $USERNAME -p $PASSWORD

Enjoy!

Comments

  • cyworld@foxmail.com[email protected] Posts: 1Member, PRO
    edited September 27

    Xcode supports uploading apps from the Organizer window or from the command line with xcodebuild or xcrun altool. Application Loader is no longer included with Xcode.

    How will it be released in the publishing?
    How to publish Appstore?

    [this post and its replies were merged into an existing thread by a moderator]

  • bob loblawbob loblaw Posts: 357Member, PRO

    this thread was up a couple of days ago

    https://forums.gamesalad.com/discussion/97546/apple-discontinued-application-loader-from-xcode-11#latest

    i’m not sure exactly what it’s all about. @adent42 could probably provide advice?

  • pinkio75pinkio75 Posts: 828Member, PRO

    not work for me! it show me this
    Error Domain=ITunesSoftwareServiceErrorDomain Code=-22014

    Any suggestion?

  • stragstrag Posts: 546Member, PRO

    ???

  • smurftedsmurfted Posts: 505Member, PRO

    Really. Is this the only way?

  • pinkio75pinkio75 Posts: 828Member, PRO

    @smurfted said:
    Really. Is this the only way?

    Yes xcode 11 not have Application Loader! so the only way for us is the terminal... honestly i don't want think this now... :(

  • jinedjined Posts: 42Member, PRO

    @pinkio75 said:
    not work for me! it show me this
    Error Domain=ITunesSoftwareServiceErrorDomain Code=-22014

    Any suggestion?

    Maybe there was a network problem, did you try agan another day?

  • pinkio75pinkio75 Posts: 828Member, PRO

    @jined said:

    @pinkio75 said:
    not work for me! it show me this
    Error Domain=ITunesSoftwareServiceErrorDomain Code=-22014

    Any suggestion?

    Maybe there was a network problem, did you try agan another day?

    Honestly i've downgrade to xcode 10.3 i've read some thing about a creation of a keystore to use xcrun etc... but i don't want to spend time now... :( and in this moment i downgrade the OS to high Sierra because is impossible to use the GS creator with Mojave... i hope a fix by GS team...

  • ArmellineArmelline Posts: 4,771Member, PRO

    Shouldn't be too hard to create a simple AppleScript application that will ask for the file to upload, ask for the username (once) and the password (every time) and then run that command. I'd have a stab at it but I'm still on Xcode 10 and don't intend to upgrade unless forced to.

  • adent42adent42 Posts: 1,418Key Master, Head Chef, Executive Chef, Member, PRO GameSalad Employee

    I'd follow advice from the thread for now.

    Generally speaking what apple does is outside our purview, though we'd like to help make it easier where we can. We'll be looking into solutions, but for now you'll need to work with submitting through the command line.

    I'm also looking into 3rd party tools that might help. Here are a few I found through googling:

    http://www.appuploader.net/index.php
    https://www.wenz.io/ApplicationLoader
    https://docs.fastlane.tools/actions/deliver/

  • tatiangtatiang Posts: 11,834Member, Sous Chef, PRO, Senior Sous-Chef

    I went ahead and merged the two threads about Application Loader.

    New to GameSalad? (FAQs)   |   Tutorials   |   Templates   |   Greenleaf Games   |   Educator & Certified GameSalad User

  • bob loblawbob loblaw Posts: 357Member, PRO

    thanks @adent42 and @tatiang

  • pinkio75pinkio75 Posts: 828Member, PRO

    thanks @adent42 for this info probably i need to buy the second! :)

  • natclarkenatclarke Brisbane, AustraliaPosts: 240Member, PRO

    I went into developer tools and downloaded Xcode 10 again which has application loader and uploaded successfully.

    Nat Clarke
    Life Cleansing

  • jay2dxjay2dx Posts: 610Member

    @natclarke said:
    I went into developer tools and downloaded Xcode 10 again which has application loader and uploaded successfully.

    how long you think this will last :/

  • pinkio75pinkio75 Posts: 828Member, PRO

    in the future we need to use the command line tool to upload the apps but probably we need some auto batch command program to facilitate the process...

  • MusicBoutiqueMusicBoutique Posts: 106Member, PRO
    edited October 25

    Xcode 11 doesn't have an application loader but you can use Transporter (also from Apple) to deliver your apps. https://apps.apple.com/us/app/transporter/id1450874784?mt=12

  • pinkio75pinkio75 Posts: 828Member, PRO

    thank you for this :)

  • bob loblawbob loblaw Posts: 357Member, PRO

    @MusicBoutique said:
    Xcode 11 doesn't have an application loader but you can use Transporter (also from Apple) to deliver your apps. https://apps.apple.com/us/app/transporter/id1450874784?mt=12

    so is that the same start process as before (put app file in a folder called ‘Payload’, zip it and change to .ipa first), before using transporter to send to apple?

  • MusicBoutiqueMusicBoutique Posts: 106Member, PRO
    edited October 26

    @bob loblaw said:

    so is that the same start process as before (put app file in a folder called ‘Payload’, zip it and change to .ipa first), before using transporter to send to apple?

    Yes exactly like the Application Loader. Just drop the .ipa into transporter and it sends to the app store.
    You seem to be complicating things however for creating .ipa - if you just click on 'Publish' at the end of the app signing process it does it automatically.

  • bob loblawbob loblaw Posts: 357Member, PRO

    @MusicBoutique said:

    @bob loblaw said:

    so is that the same start process as before (put app file in a folder called ‘Payload’, zip it and change to .ipa first), before using transporter to send to apple?

    Yes exactly like the Application Loader. Just drop the .ipa into transporter and it sends to the app store.
    You seem to be complicating things however for creating .ipa - if you just click on 'Publish' at the end of the app signing process it does it automatically.

    cheers for the tip. will add transporter to my machine.

    that publish link has never worked for me though, so that's why I go the way of making the .ipa file.

    thanks again.

  • sinbotsinbot Posts: 108Member, PRO

    The cookbook should really be updated to reflect this. I was completely unaware of this catch until I got to the final point of uploading the app file.

  • pinkio75pinkio75 Posts: 828Member, PRO

    Hi today i've try to use Transporter to upload 2 app but the result is that it stuck in
    "Authenticating with the Appstore..."

    maybe there are issue with too many connections?

    Anyway i've used Application loader and it works fine but it a little slow than other day...

    Finger crossed for the future....

  • MusicBoutiqueMusicBoutique Posts: 106Member, PRO
    edited November 7

    @pinkio75 said:
    Hi today i've try to use Transporter to upload 2 app but the result is that it stuck in
    "Authenticating with the Appstore..."
    maybe there are issue with too many connections?

    Anyway i've used Application loader and it works fine but it a little slow than other day...

    Finger crossed for the future....

    I've had no problem using Transporter so far - but been using Xcode 11... maybe there are issues with earlier versions.

  • pinkio75pinkio75 Posts: 828Member, PRO

    @MusicBoutique said:

    @pinkio75 said:
    Hi today i've try to use Transporter to upload 2 app but the result is that it stuck in
    "Authenticating with the Appstore..."
    maybe there are issue with too many connections?

    Anyway i've used Application loader and it works fine but it a little slow than other day...

    Finger crossed for the future....

    I've had no problem using Transporter so far - but been using Xcode 11... maybe there are issues with earlier versions.

    ok probably because i used xcode 10.3

    thanks

  • pinkio75pinkio75 Posts: 828Member, PRO
    edited November 7

    ok it work fine with xcode 10.3 i just need to restart the iMac.

Sign In or Register to comment.