GameSalad

Could not code sign because there is no developer identity matching the selected provisioning . . .

Trying to publish app but during "Signing app. . ." get message box: "Could not code sign because there is no developer identity matching the selected provisioning profile."

What is wrong?

I have valid Certificates in my Keychain access, both for iPhone Developer and Distribution.

The Provisioning Profile is Active and has been downloaded and opened in Xcode Organizer.

A possible problem is that the Provisioning profile in the Organizer window has a Status of "Valid signing identity not found".

There are also no keys attached to my certificates in Keychain Access. Don't know if that is a problem.

Comments

  • TokuharaTokuhara Posts: 94Member
    Sometimes it happens when you renew your apple developer program.
    You will need to reinstall the developer and distribution certificates .
    Renew your game provisioning profile at developer.apple.com, download and reinstall it with xcode.
    You can take a look at cookbook on how to install (or reinstall, same process) the certificates.
    http://cookbook.gamesalad.com/tutorials/3/parts/12
  • Gordio283Gordio283 Posts: 31Member, PRO
    edited June 2013
    Could this be a server issue? I'm noticing a lot of similar questions. I'm trying to publish my first Mac App, and I'm pretty sure I did all the steps, but the drop down menu to choose the Provisioning profile says "no mac developer certificates found"
  • dsrn@mac.comdsrn@mac.com Posts: 5Member, PRO

    I am having the same issue at the moment, was there a resolution to this??

  • tinoboss123tinoboss123 Posts: 6Member

    @Tokuhara how do i reinstall all that

  • SarahbushSarahbush Posts: 55Member, PRO

    did anyone manage to figure this out?

    I'm getting the same message - i did renew my developer account today - but i also started the whole process again (new certificated etc..) and I'm still getting the message..

    not sure what to do.

  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,901Member

    Refresh xcode. Have you set your account info in Xcode preferences? Also refresh your profiles et..

  • TheWildShroomTheWildShroom Posts: 16Member, PRO

    Open up XCode > Preferences > Accounts. Click the little + and the bottom right and add your developer account. - Done.

  • RowdyPantsRowdyPants Posts: 379Member, PRO

    @TheWildShroom This thread is from 2015 :tongue:

Sign In or Register to comment.