Display text not working on android.

It works perfectly showing "Level 001" on gamesalads viewer but when I upload and sign APK and load it onto my android phones it doesn't show anything. Please help!

Note: I have alpha set to 0 and I have graphic set as visible.

Comments

  • UltraLionBluUltraLionBlu Member, PRO Posts: 111

    If the alpha is on 0 the actor becomes invisible, it seems normal to me that he is not seen. Have you tried setting it to 1?

  • realworthygamesrealworthygames Member Posts: 20

    When I see it to 1 then I get a white rectangle around my word. But no I haven't tried it. I will try when I get home in a few hours.

  • jamie_cjamie_c ImagineLabs.rocks Member, BASIC Posts: 5,730

    Could it be a font issue? Maybe the font you picked in Gamesalad doesn't display on Android?

  • realworthygamesrealworthygames Member Posts: 20

    I am using Cambay.. how do I know if android supports it? Is there anyway to import an android approved font?

    I know I can import pictures and set it 1 by 1 but that will take forever..

  • realworthygamesrealworthygames Member Posts: 20

    Okay now I'm home.. so here is what I have in my display text.

    Display:

    "Level 00"..game.SceneGo

  • realworthygamesrealworthygames Member Posts: 20
    edited October 5

    It shows up properly on the GS viewer. What am I doing wrong?

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 1,962

    ping the support channel with a copy of your game and they may be able to help.

    my first question would be wether you uploaded the game to publishing manually or via Creator.


    To save space on your saved filed, creator inserts the fonts on publish for the "default" fonts but not when you hit "Save".


    So if you upload the file directly, then the font is missing. If you publish, that's when we insert the font.


    Otherwise, our team should be able to help.

  • realworthygamesrealworthygames Member Posts: 20

    Resolved. It works when I hit publish. I might have manually uploaded it yesterday. Thanks @adent42 !

Sign In or Register to comment.