General Release 2021-10-25: New Android Build System, RC 2021-08-04 for iOS promoted.

adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 2,413
edited November 2021 in Release Notes

Hello everybody! We moving ahead with promoting our RCs for iOS and moving to a new build system for Android.

iOS (from 2021-08-04):

Changes

  • Ad Network Updates:
    • IronSrc 7.1.5.0
    • Admob 8.4.0
    • Chartboost 8.4.1
  • Tweeting with "requestIDFA" in the image and the message should bring up the TrackingAuthorizationWithCompletionHandler

Fixes

  • requestIDFA now works properly as described above.


Android (2021-10-25)

Changes

  • New build system.
  • Target SDK: 30
  • Min SDK: 21
  • Android Billing 4.0.0
  • Ad Network updates
    • Admob: 20.3.1
    • Chartboost: 8.2.1
    • IronSrc: 7.1.11 and updates to all mediated network
  • Google Play Game Services 20.0.1

Fixes

  • Fix issue that sometimes broke 16-bit characters received in network request. It would manifest as a font rendering issue where two "blank block" characters would show where 1 should be.


Notes

I'll spare you a lot of the details, but the general advantages of the new android build system are:

1) Faster build times.

2) Fewer errors from permutations of ad networks.

3) Support for AAB with Asset Delivery (Google's replacement for expansion files).

4) Still supports APK building, now using the same process that builds AABs.

Until we release a new RC after Nov 1, 2021 (today), the RC and the Release versions are the same.

As for other questions. No, we haven't worked out aab signing on the tools yet, and we've hit a roadblock with the new 'all-in-one' signing tool approach we were looking into. We'll continue to research the best way to get app signing for both APKs and AABs in your hands and will let you know when we figure out the approach we want to take.

For now, you will need to sign your own AAB files with jarsigner. You should google "signing aab files command line". For me the top result is: https://stackoverflow.com/questions/50560045/sign-android-app-bundle-from-command-line

jarsigner -verbose -sigalg SHA1withRSA -digestalg SHA1 -keystore xample.jks bundle.aab keystoreAlias

-sigalg SHA1withRSA should be adjusted to match the algorithm of your actual keys in your keystore. SHA1withRSA and SHA1withDSA are most common, but MD5withRSA and MD2withRSA are also possible.

-keystore xample.jks , xample.jks should be replaced with the actual path to your keystore

bundle.aab should be the path to your aab file.

keystoreAlias should be the alias you used when adding your signature key to the keystore.


More details on manual signing can be found here:

Windows: https://help.gamesalad.com/windows-cookbook/publishing/android-publishing/android-app-bundle-aab-command-line-signing/

macOS: https://help.gamesalad.com/gamesalad-cookbook/publishing/4-android-publishing/android-app-bundle-aab-terminal-signing/

Comments

  • nir3112nir3112 Member, PRO Posts: 286

    Great! Thanks!

    I understand that the Fonts issue is fixed?

    from tomorrow the RC Build is newer then the “regular build” and we should use the RC?


    thanks again😊

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 2,413
    edited November 2021

    @nir3112 the "font issue" is fixed (it's really a text encoding issue in networking). RC and Regular are the same right now, so you can use either. I also added the note about the fix into the notes.

  • nir3112nir3112 Member, PRO Posts: 286

    Thank you so much! I have been waiting for this a long time and also my users😊😊😊

    I’ll update my app and let you know if there something else.

  • bob loblawbob loblaw Member Posts: 790

    so I just paid another month subscription so I can update my games. I tried to do an iOS adhoc build to test an update of one of my games on my iPhone (runs on iOS 14). I used build and rc, and both times it crashed when I tried to start up on my iPhone.

    anyone have the same problems? @adent42, any ideas?

    I don't think I've done anything different to previous times I've done adhoc or store builds, so unless I've missed something, I'm not happy if its another GS glitch.

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 2,413

    Can you DM me a publishing link @bob loblaw? I haven't had any recent problem with iOS, so I'll need to take a look.

    When you say runs on iOS 14, do you mean it runs on 14 but not on 15 or that the current version runs on 14 but not your newly generated one?

  • bob loblawbob loblaw Member Posts: 790

    thanks for getting back to me. I am running iOS14.8 on my phone(iPhone 7), but the adhoc crashes. I'm now thinking it might be the version of Xcode I'm using might need to be updated as I am getting an error message on that. will let you know what happens after I update. there doesn't seem to be any support files for ios14.8.

  • bob loblawbob loblaw Member Posts: 790

    @adent42 so I republished after installing the latest mas OS and Xcode, and it seems to work perfect. weird. not sure if was the v of Xcode or something else, but all good now. I think someone else had a similar issue recently too, so if anyone else has that some problem, maybe the remedy is something as simple as just republishing.

Sign In or Register to comment.