GameSalad

Mac Creator Release 1.25.84 is available (High Sierra Fix)

13

Comments

  • ForumNinjaForumNinja Posts: 541Key Master, Head Chef, Member, PRO GameSalad Employee
    edited January 11

    @Armelline @Hopscotch I did some investigating and it looks like what's happening is the values in saved tables aren't being wiped like they used to. I made a simple project to reproduce it and passed it over to the devs.

    I noticed that they were correctly wiped after closing and opening the project again (though that could get annoying very quickly). Are you guys also seeing these issues without saving tables?

    Edit: Looks like this effect all saving and loading of attributes, not just saving tables.

  • stragstrag Posts: 491Member, PRO

    Not sure if this is related but I was just getting loads of bug reports for my recent app update from users who updated from Google Play. Users who were installing for the first time had no issues. I'm having to get everyone to uninstall it, restart their phones and then install again. I think it must be related to table values.

  • smurftedsmurfted Posts: 493Member, BASIC

    Am i going to have to get one of my "wow's" out again here?

  • AlchimiaStudiosAlchimiaStudios Posts: 933Member, PRO

    I kinda miss release candidate builds. It's not quite a full release and not quite a beta, but it gave us a chance to track down issues like this one before it goes live.

    Follow us: Twitter - Website

  • colandercolander Posts: 1,610Member

    Pretty hard for them to do anything with two staff. The hits will keep coming with constant changes IOS, Android, OSX, etc, etc, requiring more fixes which will create more bugs in their already incredibly buggy and poorly written software. Eventually it has to overwhelm them and they will be gone. It's the death of a thousand cuts.

  • weblantisweblantis Posts: 110Member, PRO

    It`s great to see an update today. I'll test it this week.

    This is the "Best Business Box" for every Internet Marketer! Delavo BOX Is Delavo
    & Future Upgrades (incl. Delavo 3) and Lots Of Extra Goodies.

    All Details and Charter Member Discount: Click Here

  • PhilipCCPhilipCC Encounter Bay, South AustraliaPosts: 1,357Member, BASIC

    @weblantis said:
    It`s great to see an update today. I'll test it this week.

    Go back and read this post from the beginning and you might change your mind.

    And if you'd like some grief, upgrade to High Sierra. :#

  • weblantisweblantis Posts: 110Member, PRO

    Many thanks Philip - you are right I changed my mind today!

    This is the "Best Business Box" for every Internet Marketer! Delavo BOX Is Delavo
    & Future Upgrades (incl. Delavo 3) and Lots Of Extra Goodies.

    All Details and Charter Member Discount: Click Here

  • Two.ETwo.E Posts: 431Member, BASIC

    Bug#801

    When using Scene.Attributes in logic, you can only select one before it stops working, and you have to close and restart to project before you can do it for another. You can however copy a rule or behaviour that references a scene attribute, and then edit it. However simply dragging a new behaviour will not work.

    Version 1.25.(85).

    Video of Bug below:

    Best,

  • adent42adent42 Posts: 1,089Key Master, Head Chef, Executive Chef, Member, PRO GameSalad Employee

    FYI still working on fixes. Wanted to address @strag. Literally no changes to the Android engine, so probably not a new issue, or an issue related to an Android change we haven't accounted for.

  • squirrel42squirrel42 Posts: 160Member, PRO

    Thanks @adent42 any rough ETA?

  • stragstrag Posts: 491Member, PRO

    @adent42 Thanks for letting me know.

    I did actually nail down the cause of my issue. Not sure if it is a bug or my lack of understanding about how and when Tables get re-written.

    Basically I had altered one of my tables in my app update and had some of the values moved to different rows. I had also changed the naming of each row. I thought the table would get updated when someone installed the new version of my app. It did not.

    The only way to update the table was to uninstall and reinstall the app.

    So if anyone could clarify whether this is my ignorance or whether it's a bug I would appreciate it!

    Cheers

  • AlchimiaStudiosAlchimiaStudios Posts: 933Member, PRO

    @strag said:
    @adent42 Thanks for letting me know.

    I did actually nail down the cause of my issue. Not sure if it is a bug or my lack of understanding about how and when Tables get re-written.

    Basically I had altered one of my tables in my app update and had some of the values moved to different rows. I had also changed the naming of each row. I thought the table would get updated when someone installed the new version of my app. It did not.

    The only way to update the table was to uninstall and reinstall the app.

    So if anyone could clarify whether this is my ignorance or whether it's a bug I would appreciate it!

    Cheers

    This sounds like it could just be how tables work, but it's hard to say without more information. Are these tables being saved?

    The documentation here: http://help.gamesalad.com/gamesalad-cookbook/2-making-it-better/2-07-writing-to-tables/

    Has a warning about tables at the top, and tons of notes about best practice. I've also heard stories in the past of people breaking there games by updating tables and publishing an app update.

    Follow us: Twitter - Website

  • stragstrag Posts: 491Member, PRO

    @AlchimiaStudios Thanks for the link.
    It was a table which gets a couple of attributes changed during gameplay and straight after they are changed the table is saved.

    I was aware that the values do not get overwritten when the app is re-started but I thought the table would get updated when the new version of the app was installed, especially since I'd renamed the rows. I guess I was wrong and I'll think very carefully when altering tables in the future.

    Thought this was very good advice from the link you shared:

    Best practice states that it’s a good idea to have a separate table that contains the same original values as the table you’re editing, but does not get modified (basically creating a duplicate table), which then you can use the ‘Copy Table’ behavior on this duplicate to undo any changes made, followed by a ‘Save Table’ on the destination table that you’ve just copied your information to.

  • ForumNinjaForumNinja Posts: 541Key Master, Head Chef, Member, PRO GameSalad Employee

    @Two.E said:
    Bug#801

    When using Scene.Attributes in logic, you can only select one before it stops working, and you have to close and restart to project before you can do it for another. You can however copy a rule or behaviour that references a scene attribute, and then edit it. However simply dragging a new behaviour will not work.

    Thanks for letting us know. I've added it to the list.

  • smurftedsmurfted Posts: 493Member, BASIC

    & hows the list coming along may we ask?

  • PhilipCCPhilipCC Encounter Bay, South AustraliaPosts: 1,357Member, BASIC

    @smurfted said:
    & hows the list coming along may we ask?

    No you may not ask.

    Don't speak until you are spoken to... now go sit in the corner (0.0). :smirk:

  • stragstrag Posts: 491Member, PRO

    @pHghost Thanks for the explanation. I've certainly learned a lesson here and won't make that mistake again! :/

  • PhilipCCPhilipCC Encounter Bay, South AustraliaPosts: 1,357Member, BASIC

    @ForumNinja I keep waiting for the title of this thread to either be true...
    or amended! :confused:

  • dyoh777dyoh777 Posts: 17Member, PRO

    On a Mac ...

    The disappearing 'change image' issue seems related to images with spaces in the name.

    With the particle generators, I've noticed that if I don't view the image tab then it'll usually still work, but if I view the image tab then it'll show me that no image is selected and fails to use the image.

    As far as using attributes goes, you can't drag and drop from different expressions like before and even copy and paste has problems - it'll usually fail to copy the correct attribute and seems to ignore what was copied. It'll sometimes result in keeping whatever was originally in the expression box or will sometimes become a text-only string rather than the normal text-in-a-blue-box attribute. This is a pain because it makes reusing logic with slightly different expressions a very manual process.

    If I preview in full screen (I didn't see others mention this problem, sorry if I'm repeating) then the resolution choices and stretch etc. will disappear until I change the window size of the editor and then the options will reappear outside of a full screen view.

  • pHghostpHghost London, UKPosts: 2,282Member

    @dyoh777 said:
    The disappearing 'change image' issue seems related to images with spaces in the name.

    Yup, various problems caused by using spaces in file names (sounds not playing). I always use _ instead (and lowercase letters, with no special characters), to be on the safe side.

  • indra.azizindra.aziz Posts: 69Member, PRO

    Can I post a suggestion in this thread? I'm really hoping for the play sound/music behavior to have an expression editor so we can use tables. That would be super.

  • RowdyPantsRowdyPants Posts: 378Member, PRO
    edited January 27

    @indra.aziz Yes, we've been asking for that feature for a long time now.

    There's a feature request for it HERE

    You can vote for the feature.
    click 'vote', click checkbox, click 'change my vote' button

  • indra.azizindra.aziz Posts: 69Member, PRO

    @RowdyPants done! thanks. I see it's been 3 years from the request. Hopefully it can be realized.

  • Two.ETwo.E Posts: 431Member, BASIC

    Hi Team!

    I am noticing a lot of little bugs where changes are made, but they don't come into affect or can be referenced until I close the project and re-open it up.

    Another example of this is creating Tags for Actors. For the tag to be recognised in any logic, the project needs to be restarted.

    None of these are major concerns, but this seems to be the norm for a lot of things with the update.

    Are you looking for reports on all of these? I figured I should wait for the next schedule release before I take the time reporting them all.

    Best,
    Two.E

  • Twisted WireTwisted Wire Posts: 13Member, PRO

    My projects are stuck on "generating" when publishing again. Also, when I go to add a custom launch image or loading wheel, they don't save, and the next time I open the publishing portal, they're gone. Anyone else seeing either of these things?

  • myrainyworldmyrainyworld Posts: 23Member, PRO

    My projects are stuck on "generating" too. Struck on iOS side. Fine on Android.
    It would be good if we can have an indicator to know if the server is fine to generate or not.

Sign In or Register to comment.