GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Serious bugs, attributes changing on reload... :(

nicmarnicmar Posts: 7Member
edited October 2012 in Working with GS (PC)
Hi, I'm a first time game salad user, and as everyone else here, I love game development! :)

I just wanted to check it out quickly for Windows. I have a Mac too, but I'm trying to teach a friend of mine using Gamesalad, and he only has a Windows machine. But it seems very buggy. Has anyone successfully made a game on the Windows version, or is it known to have many bugs?

So I clicked Help > Report bug... but I come to a sign in page even though I'm signed in. So I'll try posting in this thread. Here's my bug report :)

1. Don't remember my attributes
- I started gamesalad, created an iPad landscape project.
- I created three actors, and chose red, green, blue colors for them
- I try to drag them to the scene.
- First nothing happened, so I dragged them several times.
- Then I clicked around a bit in the tabs. And dragged them in again. Now they are in the scene.
- So I pressed play, and all I see is a black screen.
- I quit, and saved the project, restarted gamesalad and opened my project
- Now my three actors are white, white and yellow. So if it can't keep track of my colors, how can I be sure that it will remember advanced behaviors and rules?

2. Why does it say "Project saved" each time i save? That's not normal behavior for any software?

3. If I just saved, and then try to quit, it still says "Do you want to save the changes...".

Don't get me wrong, I'd love for gamesalad to exist on the Windows platform. But these are so basic things, which scares me off from investing time in getting to know the Windows UI, and trying to create something... :(

Let me know if anyone else has these problems, or if there's something wrong with my machine.

It looked so much more friendly on the Mac as I watched tutorials, but I'm also curious if the Mac version will change to the new interface, or if the Windows UI shall coexist as different as it is. It's kind of hard to use tutorials that are made on Mac on the PC.

Well, I'll stop ranting now. Good luck with making a stable version for Windows! :)

-niclas

Comments

  • nicmarnicmar Posts: 7Member
    Also, the three white, white and yellow actors. When I check the attributes for them, they are black and red. Not at all the colors I chose before. If I edit the color, and close, it changes to the right color.
  • nicmarnicmar Posts: 7Member
    I'll keep on filing my bugs in this thread. I changed the colors back to what I wanted, then pressed play. Now only one of the actors are shown.

    Ok, so I managed to make an actor, and assign that when I touch it, it accelerates in a random direction. It's a little weird if I type random(0,360) in the "accelerate in direction" field. It doesn't work. I have to click the e-button, which also makes a popup-window that is shown outside the window.

    I activated wrapX/Y on the scene, and suddenly the scene has 4 more actors. Maybe the ones that didn't show up first when I dragged them in?

    Also, on the touch-event of the moving actor. It seems like it keeps getting the touch event as long as I hold the mouse key down, even though the actor moved, and I'm not touching it anymore.

    I added collision as an attribute for my moving actor. If it collides with the green actor, it should collide. Allright, let's go!

    Now the green actor disappeared, but when animating and bouncing, I notice that there is a black box floating around, so it must be the green one, but it's black, so it seemed invisible.

    So I changed the scene to gray, so maybe I can see the invisible actors. Clicked play. The scene is still black. What!??

    I think I could go on like this forever. I can see that it's a "Beta" but did the developers test it at all? Even the most basics things like colors should at least work.

    I'm gonna go to my Mac, and try all this again in the Mac version, which I hope is more stable. :)
  • nicmarnicmar Posts: 7Member
    On a completely different note, usability. I'm making a common error when the Scene tab i selected in the bottom left, and I click an Actor. Now I change the color of the scene, when I think I'm changing the scene.

    Maybe this should automatically select the Actors tab when I click an actore on top, and the same for scenes.

    Just saying! :)
  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,909Member
    Welcome to the world of beta software.
  • DarkpaxDarkpax Posts: 22Member
    i have the same problem but my is fatal i have an option menü with over 100 actors and all are ok but when i press play, to play in emulator , actors changed position color what else :(( it take me days to write :((( and i hate to buy a mac ... :(
    i can t come forward withz my projekt !
    all began with formatting my pc and save the save files on my external drive :(
    without formatting the saves has work . idk why ?!
    sry my bad english
  • SnapFireStudiosSnapFireStudios Posts: 1,603Member
    This sure makes me glad that they're testing this version on Windows only! :)
    - Thomas

    Ignore females. Acquire currency.

  • daveeoldaveeol Posts: 2Member

    ya I just started using game salad on windows today and it seems pretty unusable.full of bugs.very dissapointing

  • winged_boxwinged_box Posts: 52Member

    I'm doing the tutorial on basic shoot them up.

    I always got 1 extra 'Player Ship' pop up on my scene when i start the preview. Sometimes I only got 1 but the 2nd ship will mysteriously appear when my ship go out of screen and come back.

  • tatiangtatiang Posts: 11,734Member, Sous Chef, PRO, Senior Sous-Chef

    @winged_box please start a new discussion thread for your issue. What you're describing doesn't sound like a bug and someone here can likely help you.

    New to GameSalad? (FAQs)   |   Tutorials   |   Templates   |   Greenleaf Games   |   Educator & Certified GameSalad User

Sign In or Register to comment.