GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Windows 8 App Generation Broken!

selectsoftselectsoft Posts: 38Member, PRO
edited October 2012 in Working with GS (PC)
I believe it started last Friday between 1-4pm PST. Any app generated for Windows 8 after that time will no longer run. App crashes on launch. Anyone else experiencing this problem?

Comments

  • hotMagichotMagic Posts: 266Member, PRO
    Yes, I expereienced this last night, 10/15. Is this being fixed today?
  • selectsoftselectsoft Posts: 38Member, PRO
    To provide more info:

    I uploaded an app and generated final build for Windows Store Publishing on Thursday Oct, 11th. App passed our testing and was submitted to Microsoft with a current status of "in content testing" (has passed technical testing phase).

    Friday morning, I uploaded a 2nd app for pre-final testing and the generated build worked perfectly fine (around 10am PST). At around 2pm that same day, I uploaded the final project and downloaded the final generated Windows Store app about 15 minutes later. App failed and crashed on launch.

    I've tested 2 other different projects with the same outcome.

    Finally to confirm the problem was indeed a generation issue on GameSalad side, I re-generated (did not re-upload) my 1st project that I already submitted to Windows Store. Sure enough, app failed.

    My contact at Microsoft informed me that the deadline for having an app up on Windows Store by Windows 8 release day was Friday. If this issue was nonexistent, I would of had a total of 3 apps on the store on Windows 8 release.
  • hotMagichotMagic Posts: 266Member, PRO
    edited October 2012
    Yeah it's frustrating. I have one stuck on Generating for a day, and the app built fine last week. @saladstraightshooter , is this being fixed?
  • SaladStraightShooterSaladStraightShooter Austin, TxPosts: 3,081Member, Chef Emeritus
    @hotmagic, @selectsoft - currently Windows 8 publishing is online and functional. The issue has been that a user uploaded a massive app which was then caught in a generating loop that caused the entirety of the pipeline to back up.

    Normally there is a failsafe that will reject an app if it fails generating - in this case that failsafe did not trigger and the system kept trying to generate the same failed app. Generation is not "broken" - it was merely stuck chewing on the same failed data.

    We're seeing apps generating fine at the moment, however. We should have a tweak that accounts for larger-than-average apps in the pipeline at some point in the near future.

    (Also, please note that I am not support in the traditional sense... our support team is working hard to respond to request actually sent in to support. I answer questions when possible, but any slow response on my side is not indicative of support's time table.)

    Why do you keep using that word? I do not think it means what you think it means.

  • selectsoftselectsoft Posts: 38Member, PRO

    @hotmagic, @selectsoft - currently Windows 8 publishing is online and functional. The issue has been that a user uploaded a massive app which was then caught in a generating loop that caused the entirety of the pipeline to back up.

    Normally there is a failsafe that will reject an app if it fails generating - in this case that failsafe did not trigger and the system kept trying to generate the same failed app. Generation is not "broken" - it was merely stuck chewing on the same failed data.

    We're seeing apps generating fine at the moment, however. We should have a tweak that accounts for larger-than-average apps in the pipeline at some point in the near future.

    (Also, please note that I am not support in the traditional sense... our support team is working hard to respond to request actually sent in to support. I answer questions when possible, but any slow response on my side is not indicative of support's time table.)

    Ok, do I need to wait longer for the app to generate then? Thanks for the quick response.
  • SaladStraightShooterSaladStraightShooter Austin, TxPosts: 3,081Member, Chef Emeritus
    @selectsoft - you should be green to generate. How large is your app?

    Why do you keep using that word? I do not think it means what you think it means.

  • LeonardDeveloperLeonardDeveloper Posts: 4,630Member
    Just worked fine for me on a short test... I'm 34mbs if that helps?
  • hotMagichotMagic Posts: 266Member, PRO
    I just heard from support. @StraightSaladShooter this was important enough that I spammed all of you :)

    and yes they have been really responsive, as promised. They said a fix is in progress, so I'll be testing our game soon (40mb).

  • selectsoftselectsoft Posts: 38Member, PRO
    @hotmagic

    Just to confirm, your app crashes on launch correct?
  • hotMagichotMagic Posts: 266Member, PRO
    @selectsoft @straightsaladshooter
    I managed to capture the error by doing a break point in visual studio which I'll send to support.

    Im able to build now, but the crash remains. Can anyone build with no crash right now? When running in the power shell?
This discussion has been closed.