Testing my app

creyecreye Member, BASIC Posts: 16
edited September 2017 in Working with GS (PC)

Hello guys,

So this is going to be my first, and hopefully last, post where I'm bordering to whining. Also, apologies for the wall of text, but I feel like I need to give all relevant information. This is very disheartening to me.

Me and my brother have been working on our first project together. We basically went for perhaps a bit bigger project than we should've for our first, we've spent maybe 2 months working on this app so far. Although that's irrelevant to my issue.

We've come to the point where we need to start testing what we build just to make sure it works and isn't wasted. I'd say it's especially important since it's our first project and we don't really know the usual pitfalls of beginners. And this is what we can't get to work.

Our choice of platform for this is GameSalad Viewer. We've been trying on 2 different systems (both Win10) with 5 different devices (2 Apple/iOS, 3 Samsung/Androids).

Now, we work remotely together since we're 800 kms apart, so I can't really give the exact account of how my brother experiences the issues, although as I understand it they are the same or very similar to mine.

Android device: Samsung S4 Mini

Problem description:
The device simply wont show up in GameSalad (the little Android icon), and on the device it wont show that it can find GS Creator.
I run it with both WiFi connected and USB connected. Interresting behaviour here is that the GS app on the device says it's connected by USB regardless if it is or not - even if I reboot the phone with USB disconnected, it will still say it's connected by USB when GS viewer is started.
For this tricky installation, for which the guide to me seems to be out of date, I've followed this guide: http://help.gamesalad.com/windows-cookbook/publishing/android-publishing/1-getting-started-with-android/

  • I've installed Android Studio,
  • And the Java SDK,
  • I've added the ADB.exe correctly in the path in GS creator

The only thing I don't know if it's done correctly is the java connection to Android studio, since the installation don't prompt the same thing as showed in guide. There is however no other download on the page directed to, so if it's not android studio, then what? (As far as I know, the guide is just a bit outdated and the Android studio is what needs to be installed).

Next up, iOS...

iOS device(s): iPhone SE, iPad Air

Problem description:
Honestly, I've tried GS viewer on these a number of times but I didn't really put weeks into it. Just a few nights of frustration. I've installed the GS viewer on the devices.

  • They get connected to Creator.
  • They apple symbol pops and I can "start the app" on the devices
  • GS viewer on the devices goes to load screen
  • BOOM, stuck on 0%. Indefinitely.

The GS support don't answer beyond giving the link to the general info page on app store, so that was little help. (And GS support, if you're reading this, sorry for telling Alexandra to shut the !@#$% up, but that bot drives me crazy).

In all honesty, maybe I'm just missing out on obvious things, especially in regards to the iOS devices. Maybe more reading will show me I'm required to get a developer account already for this, or whatever. But I thought I should ask you guys before I perma-delete all my files out of anger - I might just end up doing that before I get to a solution to this. That's how it feels.

As always, I appreciate any help or suggestions. Thank you for reading.

TLDR: Can't get GS viewer testing to work. Am about to sink my files into the ocean.



  • tatiangtatiang Member, Sous Chef, PRO, Senior Sous-Chef Posts: 11,926
    edited September 2017

    Yep, it's frustrating! I hear you. I just went through a similar thing with my Android phone. I never did get it to work wirelessly but via USB I can sometimes connect. Besides this:

    I've installed Android Studio,
    And the Java SDK,
    I've added the ADB.exe correctly in the path in GS creator

    I have to put the phone in USB Charging Mode and disable the SD card.

    I've been having similar problems with an iPhone and finally decided to set up an ad hoc installing in Xcode and... it so much simpler once it's working (not simple to set up though). If there's a comparable ad hoc method for android you might try that -- sorry, I know very little about android devices save what I just explained.

    On the iOS side, can you preview one of the sample project files (e.g. Big Top Blaster) in GS Viewer?

    New to GameSalad? (FAQs)   |   Tutorials   |   Templates   |   Greenleaf Games   |   Educator & Certified GameSalad User

  • creyecreye Member, BASIC Posts: 16

    @tatiang thank you for your reply.

    In a week where babies and work take up all my energy and time, I will dedicate my weekend to dealing with this issue with the advice you've given me. I will respond to this thread once I tried it out.

    Again, thank you.

Sign In or Register to comment.