GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Target API level requirements from August 2019

shnibitdohgetshnibitdohget Posts: 3Member, PRO

Google Play store is requiring the target API level to be 28 or higher right now. Currently GS is publishing mine at 26. Is there a fix for this?

Target API level requirements from August 2019
Warning:

Your app currently targets API level 26 and must target at least API level 28 to ensure it is built on the latest APIs optimized for security and performance.

From August 2019, new apps must target at least Android 9.0 (API level 28).
From November 2019, app updates must target Android 9.0 (API level 28).

Comments

  • adent42adent42 Posts: 1,344Key Master, Head Chef, Executive Chef, Member, PRO GameSalad Employee
    edited June 18

    Once the RC build becomes main, we can push an update to let you hit the correct minimum.

  • adent42adent42 Posts: 1,344Key Master, Head Chef, Executive Chef, Member, PRO GameSalad Employee
    edited June 18

    So to clarify. The RC targets SDK 28. So if you want to update that part now, you can by using the RC. You will also run into a requirement for 64-bit binaries, which we will be working on releasing sooner than later.

  • shnibitdohgetshnibitdohget Posts: 3Member, PRO

    @adent42 Will google still accept it if it's 32-bit and un-optimized?

  • MotisGamesMotisGames Posts: 15Member, PRO

    @shnibitdohget said:
    @adent42 Will google still accept it if it's 32-bit and un-optimized?

    For now, yes. And I'm sure GS will have it sorted out by the time its mandatory.

Sign In or Register to comment.